Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[EXCEL] FORMULA MEDIA PONDERATA CON CERCA VERTICALE

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[EXCEL] FORMULA MEDIA PONDERATA CON CERCA VERTICALE

Postdi Danivan » 28/07/12 14:57

Ciao,
sono giorni che stò lavorando su una cartella Excel con diversi fogli ed avrei bisogno di effettuare una media ponderata in una colonna, riportando i valori da un altro foglio, solo se corrisponde la cella di un altra colonna.
Vi spiego meglio:
Nel "foglio1" ho inserito degli articoli con il codice nella "colonna A", la quantità nella "colonnaD" ed il prezzo nella "colonnaE"; in questo foglio può capitare che nella "colonnaA" ho più volte lo stesso codice però a volte il prezzo nella "colonnaE" cambia.
Siccome nel "foglio2" ho il riepilogo degli articoli, senza però ripetizioni di codice nella "colonnaA", ma ho fatto in modo di sommare la quantità quando ho lo stesso "codice articolo" (con il cerca verticale), adesso avrei bisogno di fare una media ponderata del prezzo solo riferito a quel determinato articolo.
Ho provato a fare anche solo una media con questa formula ma non funziona...
=MEDIA(CERCA.VERT(A744;acquisto;5;FALSO)) non mi fa nessuna media ma mi riporta il prezzo del primo codice articolo che trova nel "folgio1".
Qualcuno saprebbe aiutarmi ???? Stò inpazzendo a forza di provare formule !!!!

Grazie Dany
Danivan
Utente Junior
 
Post: 77
Iscritto il: 26/08/08 19:19

Sponsor
 

Re: [EXCEL] FORMULA MEDIA PONDERATA CON CERCA VERTICALE

Postdi Flash30005 » 28/07/12 17:38

Con una macro come questa ottieni la somma media ponderale in colonne E del foglio2
Codice: Seleziona tutto
Sub Riep()
Set Ws1 = Worksheets("Foglio1")
Set Ws2 = Worksheets("Foglio2")
UR1 = Ws1.Range("A" & Rows.Count).End(xlUp).Row
UR2 = Ws2.Range("A" & Rows.Count).End(xlUp).Row
Ws2.Range("D2:E" & UR2).ClearContents
For RR2 = 2 To UR2
Cod2 = Ws2.Range("A" & RR2).Value
For RR1 = 2 To UR1
Cod1 = Ws1.Range("A" & RR1).Value
If Cod1 = Cod2 Then
Ws2.Range("D" & RR2).Value = Ws2.Range("D" & RR2).Value + Ws1.Range("D" & RR1).Value
Ws2.Range("E" & RR2).Value = Ws2.Range("E" & RR2).Value + (Ws1.Range("E" & RR1).Value / Ws1.Range("D" & RR1).Value)

End If
Next RR1
Next RR2
End Sub

Con una semplice moltiplicazione (formula in F) avrai il totale prezzo

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: [EXCEL] FORMULA MEDIA PONDERATA CON CERCA VERTICALE

Postdi PcBase » 28/07/12 17:40

Windows xp + Office 2003 Ita
Windows8 Office 2013
PcBase
Utente Senior
 
Post: 129
Iscritto il: 24/02/11 23:26


Torna a Applicazioni Office Windows


Topic correlati a "[EXCEL] FORMULA MEDIA PONDERATA CON CERCA VERTICALE":

Formula Rif.riga
Autore: salatony
Forum: Programmazione
Risposte: 0

Chi c’è in linea

Visitano il forum: Nessuno e 15 ospiti