Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

somma prodotto

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

somma prodotto

Postdi Mister steve » 22/07/12 13:20

Ciao a Tutti
come capirete sono un nuovissimo utente
sono giorni che cerco di risolvere un problema di excel
In un File ho i venduti
Canale Ragione Sociale Venduto coll. 44 Venduto coll. 45 Venduto coll. 46
in un altro ho le stesse colonne ma mi devo inserire i dati del venduto delle stagioni soprariportate considerando che il venduto deve corrispondere per ragione sociale e canale.
ho provato con la formula
=+MATR.SOMMA.PRODOTTO(--(Foglio2!$H$5:$H$3895=Foglio2!H5);(--(Foglio2!$K$5:$K$3895=Foglio2!K$5)*Foglio2!AD$5:AD$3895))
dove h corrisponde al canale k alla ragione soc e ad alla colonna del venduto da riportare.

CERCARE DI SPIEGARMI MEGLIO
Foglio 2
Canale Ragione Sociale Venduto coll. 44 Venduto coll. 45 Venduto coll. 46
NOME1 PIPPO 23 50 80
NOME2 PIPPO 0 8 100
NOME1 PLUTO 14 23 43
NOME1 PLUTO 12 14 76
i numeri sono relativi alle colonne venduti
Data Base
Canale Ragione Sociale Venduto coll 46
NOME1 PIPPO
NOME2 PIPPO
MOME 1 PLUTO
NOME2 PLUTO
dove nella colonna venduto cool 46 mi devo riportare i dati del folgio due


Mi potete aiutare
Grazie
Mister steve
Mister steve
Newbie
 
Post: 5
Iscritto il: 22/07/12 11:19

Sponsor
 

Re: somma prodotto

Postdi Anthony47 » 22/07/12 16:52

Ciao Mister steve, benvenuto nel forum.

Non e' chiaro quali sono le coordinate, nel tuo file, dei dati che hai menzionato; puoi allegare uno screenshot o un file esemplificativo? (per come fare guarda qui: viewtopic.php?f=26&t=80395. Per allegare il link forse dovrai avere almeno tre messaggi pubblicati, eventualmente scrivine qualcuno solo per arrivare a tre...)

Intanto ti anticipo che secondo me una semplice "Tabella pivot" ti darebbe tutte le risposte che cerchi; dettagli sempre (se servono) dopo il chiarimento chiesto sopra.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: somma prodotto

Postdi Mister steve » 22/07/12 19:16

Ciao Anthony
grazie per l'interessamento
Il file allegato è molto semplificato.
in poche parole ho bisogno di trasferirmi i dati dal Foglio2 al database (che non è ugule al foglio2)
i dati da esportare sono i venduti coll che devono corrispondere al canale e alla ragione soc.
Mille grazie
Mister Steve
https://rapidshare.com/files/2438856921/VENDITE.xlsx
Mister steve
Newbie
 
Post: 5
Iscritto il: 22/07/12 11:19

Re: somma prodotto

Postdi Anthony47 » 23/07/12 00:30

Prova in Q3 di foglio DataBase
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(Foglio2!$B$2:$B$100='Data Base'!$B3);--(Foglio2!$E$2:$E$100='Data Base'!$D3);Foglio2!R$2:R$100)

Se pensi di avere in Foglio2 piu' di 100 righe varia quei tre $100 in $1000 o $10000, un valore sufficiente a starci sempre dentro.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: somma prodotto

Postdi Mister steve » 23/07/12 08:00

Ciao Anthony
Mille grazie
tutto OK
Mister Steve
Mister steve
Newbie
 
Post: 5
Iscritto il: 22/07/12 11:19


Torna a Applicazioni Office Windows


Topic correlati a "somma prodotto":


Chi c’è in linea

Visitano il forum: Nessuno e 13 ospiti