Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formula excel - nuovo quesito

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formula excel - nuovo quesito

Postdi Lucio Peruggini » 10/06/12 22:14

ERRORE FORMULA

Ciao
Avrei un altro quesito da porre. Nella colonna “O2:O50” ho inserito la formula seguente:

=SE(M2=3;PICCOLO(I2:K2;1)) ma, quando in essa vi si trova un valore differente che può variare da minimo 3 a massimo 9, ovviamente mi dà come risultato (falso”). Quale è la formula giusta affinché in una qualunque cella della colonna “O2:O50” e qualunque sia il valore riscontrato da 1 a 9 mi scriva il più piccolo a seconda del gruppo che considera?

In pratica, in “M2” abbiamo una valore 3; la formula riscontra il più piccolo del gruppo “I2:K2”.
Se avessimo avuto valore 4 come in “M3”, il più piccolo del gruppo 4 “H3:K3” è “H3”
Se avessimo avuto valore 5 come in “M5”, il più piccolo del gruppo 5 “G5:K5” è “J5”

Fino ad arrivare a un valore 9 che rileverà il più piccolo da “C a K”.

Saluti

http://s19.postimage.org/7hvcql9ar/immagine_2.png
Lucio P.
Versione Office - 2013
Lucio Peruggini
Utente Senior
 
Post: 890
Iscritto il: 24/01/11 16:23

Sponsor
 

Re: Formula excel - nuovo quesito

Postdi Anthony47 » 10/06/12 23:58

Prova con
Codice: Seleziona tutto
=PICCOLO(SCARTO(I2;$M$2-3;-($M$2-3);1;$M$2);1)

Ma la formula funziona con M3 tra 3 e 9 (non 1-9, che presuppone di avere piu' colonne a disposizione).

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula excel - nuovo quesito

Postdi Lucio Peruggini » 11/06/12 13:57

Grazie, ho risolto con un bel po di condizioni ma funziona perfettamente svolgendo il suo compito.

Ho messo la colonna "M" in ordine crescente 3-4-5-6-7-8-9 e poi ho impostato le condizioni sottostanti.

=SE(M3=3;PICCOLO(I3:K3;1);SE(M3=4;PICCOLO(H3:K3;1);SE(M3=5;PICCOLO(G3:K3;1);SE(M3=6;PICCOLO(F3:K3;1);SE(M3=7;PICCOLO(E3:K3;1);SE(M3=8;PICCOLO(D3:K3;1);SE(M3=9;PICCOLO(C3:K3;1))))))))

Saluti
Lucio P.
Versione Office - 2013
Lucio Peruggini
Utente Senior
 
Post: 890
Iscritto il: 24/01/11 16:23

Re: Formula excel - nuovo quesito

Postdi Anthony47 » 11/06/12 14:12

Leggendo la formula adottata potrebbe essere che si chiede il calcolo del minore "sulla riga corrente" per un numero di colonne variabile da 3 a 9 che terminano sempre in col K.

Se e' cosi', con riferimento all' immagine pubblicata, in S2 (o altra cella di riga 2) si usa la formula
Codice: Seleziona tutto
=PICCOLO(SCARTO($I2;0;-($M2-3);1;$M2);1)

Poi si copia verso il basso.
In ogni caso non capisco il bisogno di mettere col M "in ordine crescente 3-4-5-6-7-8-9", quindi iol rischio che la formula non sia idonea per quello che devi fare e' alto.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula excel - nuovo quesito

Postdi Lucio Peruggini » 11/06/12 18:15

Ciao Anthony, questa formula funziona benissimo e senz’altro più corretta oltre che più breve. Ad ogni modo, anche la soluzione da me adottata funziona pur avendo valori misti in colonna “O”.

Comunque grazie, ho adottato la tua.
Lucio P.
Versione Office - 2013
Lucio Peruggini
Utente Senior
 
Post: 890
Iscritto il: 24/01/11 16:23


Torna a Applicazioni Office Windows


Topic correlati a "Formula excel - nuovo quesito":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti