Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

creare elenco senza buchi

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

creare elenco senza buchi

Postdi erryrox » 30/05/12 15:18

Buonasera, espongo subito il problema:
nella colonna A ho un elenco di nomi con un determinata struttura (PROVA_1, PROVA_2....). Nella stessa colonna però vi sono anche celle vuote o con altri tipi di nomi. Io dovrei crearmi un nuovo elenco in un altra colonna con solo i nomi che servono a me (PROVA_1, PROVA_2...).

Esiste un modo per farlo tramite qualche funzione??? NO MACRO :)

Grazie
erryrox
Utente Junior
 
Post: 60
Iscritto il: 16/04/12 14:31

Sponsor
 

Re: creare elenco senza buchi

Postdi erryrox » 30/05/12 15:22

ho risolto così:

una creato una colonna di appoggio (B) con una numerazione progressiva (1,2,3,4,5,6....). Accanto a questa colonna ho inserito la formula =CERCA.VERT("PROVA_"&B1;$A:$A;1;0). In questo modo mi crea un elenco senza buchi di solo nomi che iniziano con "PROVA_".

Se avete soluzioni migliori fatemi sapere! ciao
erryrox
Utente Junior
 
Post: 60
Iscritto il: 16/04/12 14:31

Re: creare elenco senza buchi

Postdi carpato82 » 31/05/12 09:04

ciao erryrox,
ma nell'elenco che hai, potrebbe capitare che la parola es. "prova_1" compare più volte?

Ciao,
A
carpato82
Newbie
 
Post: 8
Iscritto il: 23/05/12 09:04
Località: Milano

Re: creare elenco senza buchi

Postdi erryrox » 31/05/12 09:15

Ciao, per fortuna non capita...altrimenti il caro CERCA.VERT impazzirebbe! :)
erryrox
Utente Junior
 
Post: 60
Iscritto il: 16/04/12 14:31

Re: creare elenco senza buchi

Postdi Anthony47 » 31/05/12 11:35

A puro scopo didattico, questa formula restituisce le celle il cui contenuto comincia con quanto scritto in H1:
Codice: Seleziona tutto
=INDICE($A$1:$A$200;PICCOLO(SE(SINISTRA($A$1:$A$200;LUNGHEZZA($H$1))=$H$1;RIF.RIGA($A$1:$A$200);"");RIF.RIGA(A1)))
Da confermare con Contr-Maiusc-Enter
Gestisce anche occorrenze multiple della stessa voce.
Se il tuo elenco va oltre la riga 200 adatta la formula, rispettando la sintassi data.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: creare elenco senza buchi

Postdi carpato82 » 31/05/12 13:02

che si intende per "Da confermare con Contr-Maiusc-Enter"?
Grazie,
A
carpato82
Newbie
 
Post: 8
Iscritto il: 23/05/12 09:04
Località: Milano

Re: creare elenco senza buchi

Postdi Anthony47 » 31/05/12 21:36

Significa che una volta scritta la formula nella barra della formula bisogna premere Contr, Maiusc e poi Enter (invece del solo Enter, o Invio, o come si chiama sulla tastiera). Vedrai la formula racchiusa tra parentesi graffe (e sia chiaro che digitare invece le parentesi graffe da tastiera non e' assolutamente la stessa cosa).
Per informazioni piu' generose guarda l' help on line di excel, alla voce (ricerca libera) "Informazioni sulle formule in forma di matrice"

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: creare elenco senza buchi

Postdi carpato82 » 05/06/12 10:58

Grazie mille Anthony.
Ciao,
A
carpato82
Newbie
 
Post: 8
Iscritto il: 23/05/12 09:04
Località: Milano


Torna a Applicazioni Office Windows


Topic correlati a "creare elenco senza buchi":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti

cron