Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Cerca Vert con 2 valori

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Cerca Vert con 2 valori

Postdi Black.Jack » 30/05/12 14:34

Ciao,


ho cercato un'altra discussione simile ma non ho trovato nulla di utile\comprensibile :oops:


Sono solito sfruttare le macro per riuscire in qualsiasi impresa, ma ora vorrei affinare l'efficacia delle formule più complesse, magari anche matriciali (che conosco superficialmente).

Il caso che sottopongo è una cerca verticale che agisca portando il valore di una terza colonna, dopo aver verificare la corrispondenza, nella medesima riga, di 2 valori provenienti da una posizione iniziale.

Sostanzialmente la solita cerca verticale, solo che i valori di confronto sono 2 e non 1.

Magari la formula utile non sarà + cerca verticale...ma l'ho usata per spiegarvi cosa mi servirebbe... ;)


grazie anticipatamente a tutti!!!
Win7 + Office 2010 Ita
Xp + Office 2010 Ita
Black.Jack
Utente Junior
 
Post: 93
Iscritto il: 23/06/10 08:40

Sponsor
 

Re: Cerca Vert con 2 valori

Postdi patel » 30/05/12 14:47

un esempio non guasterebbe, comunque la funzione matrice.somma.prodotto potrebbe essere utile al tuo scopo, vedi http://www.excelling.it/index.php?optio ... &Itemid=57
patel
Utente Senior
 
Post: 122
Iscritto il: 24/04/12 16:03

Re: Cerca Vert con 2 valori

Postdi Black.Jack » 30/05/12 15:19

grazie patel!!!


capisco la somma prodotto, per quanto grossolanamente credo d'aver capito, restituirebbe due valori positivi in caso di duplice ricerca di "corrispondenza"....però bisogna impostare la medesima riga per entrambe le corrispondenze....


Un esempio

Foglio1:

Nome|Cognome
Marco|Verdi
Mario|Rossi


Foglio2:

Nome|Cognome|Età
Marco|Verdi |18
Marco|Rossi |20
Mario |Bianchi |33


Applicando una formula nella colonna "C" del Foglio1 (a fianco a "Verdi" per intenderci) dovrebbe restituire "18" e "non trovato" o Null per Mario Rossi.


Spero di essermi spiegato ! ;)
Win7 + Office 2010 Ita
Xp + Office 2010 Ita
Black.Jack
Utente Junior
 
Post: 93
Iscritto il: 23/06/10 08:40

Re: Cerca Vert con 2 valori

Postdi CANAPONE » 30/05/12 15:33

Ciao a tutti,

la formula restituisce un valore dalla colonna C del foglio2 (intervallo C1:C1000 nell'esempio) nel caso riconosca una doppia corrispondenza con A2 e B2 (nome e cognome che cerchiamo nelle colonne A e B del foglio2)


Codice: Seleziona tutto
=INDICE(Foglio2!C$1:C$1000;CONFRONTA(A2&B2;INDICE(Foglio2!A$1:A$1000&Foglio2!B$1:B$1000;0);0))


Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Cerca Vert con 2 valori

Postdi Black.Jack » 30/05/12 15:43

Fantastico....grazie Canapone, sembra anche abbordabilissima!! mi metto ad approfondire indice e confronta.

grazie mille anche a patel, sicuramente anche matr.somma.prod è un'utissima funziona dalle molteplici sfaccettature: da approfondire assolutamente!! ;)
Win7 + Office 2010 Ita
Xp + Office 2010 Ita
Black.Jack
Utente Junior
 
Post: 93
Iscritto il: 23/06/10 08:40

Re: Cerca Vert con 2 valori

Postdi CANAPONE » 30/05/12 16:14

Ciao,

il secondo INDICE serve solo ad evitare di chiedere do confermare la formula con control+maiusc+invio

Codice: Seleziona tutto
=INDICE(Foglio2!C$1:C$1000;CONFRONTA(A2&B2;Foglio2!A$1:A$1000&Foglio2!B$1:B$1000;0))


Grazie del cortese riscontro

Alla prossima
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze


Torna a Applicazioni Office Windows


Topic correlati a "Cerca Vert con 2 valori":


Chi c’è in linea

Visitano il forum: Nessuno e 14 ospiti