Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

formula: INDIRETTO

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

formula: INDIRETTO

Postdi giorgioa » 26/05/12 15:26

Non riesco e venirne fuori, se mi potete aiutare.
DATI:
foglio1= archivio;
foglio2=Freq_1
in archivio da c2 a v2 i 20 venti numeri per riga fino a x riga;
in Freq_1 al primo rigo da G1 e a seguire i numeri da 1 a 90(che sono g$1, g$2 ecc);
in f7 un numero che farebbe riferimento ad una riga dell'archivio;
in G7 la formula =CONTA.SE(INDIRETTO(archivio!"$c"&$f7&:archivio!"$w"&f7&);g$1)
il conta.se va a vedere se al rigo x di archivio c'è il numero g$1 di Freq_1;
INDIRETTO vorrei che mi leggesse in archivio il numero di riga posto in f7 (frq_1)
Premetto che in Freq_1 le formule da g7 verranno distribuite fino a g20-30.
Dove faccio l'errore nella formula?
Ringrazio, salve.
giorgioa
Utente Senior
 
Post: 544
Iscritto il: 16/04/12 15:00

Sponsor
 

Re: formula: INDIRETTO

Postdi CANAPONE » 26/05/12 15:45

Ciao Giorgio,

prova:

Codice: Seleziona tutto
=CONTA.SE(INDIRETTO("archivio!$C"&$F7&":$W"&$F7);G$1)


Spero sia d'aiuto

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: formula: INDIRETTO

Postdi giorgioa » 26/05/12 23:54

Salve Canapone,
la formula funziona cioè quando trova il numero nell'archivio da il segno 1,
invece vorrei al posto del segno 1 il numero indicato nella riga 1.
Ho aggiunto il SE per togliermi 0(zero) però vorrei il numero al posto dell'uno:

=SE(CONTA.SE(INDIRETTO("archivio!$C"&$F7&":$W"&$F7);G$1)<>1;"";G$1)
Comunque ti ringrazio.
giorgioa
Utente Senior
 
Post: 544
Iscritto il: 16/04/12 15:00

Re: formula: INDIRETTO

Postdi giorgioa » 27/05/12 00:23

Salve Canapone,
così com'è cioè come lo descritta con l'aggiunta del se mi da quello che desidero cioè il numero.
E' successo che quando ho aggiunto il se sono rimasto a calcolare dove c'è il segno 1 e per questo
rimaneva giustamente l'uno poi dopo che ti scritto ho provato a tascinare le formule ed ho visto che
funziona perfettamente.

La gatta frettolosca fa i figli ciechi (è un nostro detto).
Saluti e buona domenica
giorgioa
Utente Senior
 
Post: 544
Iscritto il: 16/04/12 15:00


Torna a Applicazioni Office Windows


Topic correlati a "formula: INDIRETTO":


Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti