Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formattazione condizionale:Formula

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formattazione condizionale:Formula

Postdi Statix » 21/05/12 06:39

Ciao a tutti,
ho un problema per una formula di formattazione condizionale,
le celle della formattazione condizionale sono variabili.
la formula attuale è questa
=CONTA.SE($AU$7:$AU$16;H8:L27)>0
in una cella AU4 ho un rif.riga() esempio 22
dovrei fare che la formula si adatti alla riga,
=CONTA.SE($AU$7:$AU$16;H22:L27)>0
altro esempio rif.riga()=25
=CONTA.SE($AU$7:$AU$16;H25:L27)>0
il valore di rif.riga() è sempre in cella AU4
grazie.
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Sponsor
 

Re: Formattazione condizionale:Formula

Postdi wallace&gromit » 22/05/12 07:44

Ciao Statix,
secondo me hai un problema di fondo con la formula (non penso possa darti quello che vuoi tu).
Prima di tutto esprimi quale è la tua necessità di formato condizionale, in un secondo tempo si potrà vedere come applicarla ad un range variabile.

P.S. se io applico il conta.se come l'hai scritto tu ottengo il numero di volte che nel range di base trovo il primo valore della seconda lista (per es. H22), non un confronto di tutta la serie
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: Formattazione condizionale:Formula

Postdi CANAPONE » 26/05/12 10:32

Ciao

prova come regola di attivazione della formattazione condizionale:


Codice: Seleziona tutto
=SOMMA(CONTA.SE($AU$7:$AU$16;INDIRETTO("H"&$AU$4&":L$27")))


Fai sapere se va bene.

Una caro saluto a Wallace&Gromit
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Formattazione condizionale:Formula

Postdi Statix » 26/05/12 14:45

Ciao a tutti,
xCanapone la formula non funziona,
comunque ho risolto in altro modo ,
ho messo la formula della formattazione condizionale classica a tutto il range,
al range delle celle variabili ho messo una condizione, se il valore è uguale o maggiore di Au4....
così facendo visualizzo solo la parte del range che mi serve e la formattazione applicata fa il resto,
per fare un esempio e come avere una tendina al range delle estrazioni,
AU4= 5 ,mi visualizza le ultime 5,se AU4=15,mi visualizza le ultime 15,e la formattazione condizionale agisce solo su quella parte evidenziata,fatto in questo modo rende anche più agevole la lettura dei dati rimasti
senza che le altre celle interferiscono.
grazie
in questo caso dovevo applicare la formattazione condizionale alle ultime 12 estrazioni,
ecco come
ho fatto

Immagine
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Formattazione condizionale:Formula

Postdi CANAPONE » 26/05/12 15:13

Ciao Statix,

grazie del cortese riscontro: molto interessanti il lavoro.

Avevo capito un'altra cosa: mi capita spesso.

Prendendo spunto dai

=CONTA.SE($AU$7:$AU$16;H8:L27)>0


ho modificato la formula in

=SOMMA(CONTA.SE($AU$7:$AU$16;H8:L$27)))

in modo che se nell'area H8:L27 fosse comparso uno dei numeri presenti in H8:L27 la cella - esempio- diventasse rossa.

Usando poi indiretto, ho spostato all'esterno - in AU4 - l'indicazione della riga della colonna H dove far partire il conteggio

=SOMMA(CONTA.SE($AU$7:$AU$16;INDIRETTO("H"&$AU$4&":L$27")))

Una cosa interessante della formattazione condizionale è che legge queste formule come se fossero matriciali, senza il control+maiusc+invio,

La formattazione condizionale nell'esempio è impostata solo nella cella E6, fuori da H4:L27

Giro l'esempio dove avevo fatto una prova.

http://wikisend.com/download/332612/Saluti.xls

Alla prossima, saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze


Torna a Applicazioni Office Windows


Topic correlati a "Formattazione condizionale:Formula":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti