Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Posizione di una variabile nella funzione Piccolo

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Posizione di una variabile nella funzione Piccolo

Postdi tutamimetica » 14/05/12 15:18

Ho nella colonna A diversi valori e volendo calcolare i valori dal più piccolo al più grande ho utilizzato in C1=PICCOLO($A$1:$A$150;1)
C2=PICCOLO($A$1:$A$150;2) ecc.
in D1 dovrei calcolare la POSIZIONE del valore più piccolo (calcolato nella colonna C) occupato nella colonna A
e ho proceduto come segue:
Ho creato nella colonna B1=1, B2=2, B3=3 ... B150=150
e a partire da D1 ho inserito la seguente formula
CERCA.VERT(C1;$A$1:$B$150;2;0)
CERCA.VERT(C2;$A$1:$B$150;2;0)
Ho analizzato i risultati e ho notato che se sono presenti più numeri mi segna la stessa posizione
esempio
A1=1 A2=4 A3=3 A3=3 A5=3
il risultato viene
1 5 2 2 2
è possibile avere come risultato 1 5 2 3 4
grazie dell'aiuto
Tuta
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25

Sponsor
 

Re: Posizione di una variabile nella funzione Piccolo

Postdi Flash30005 » 14/05/12 18:17

(Da un post di Anthony http://www.pc-facile.com/forum/viewtopic.php?f=26&t=95296&p=545832#p545832)

In B1 inserisci questa formula
Codice: Seleziona tutto
=A1*1000+RIF.RIGA()

e in D1 questa
Codice: Seleziona tutto
=SE(B1<>0;RANGO(B1;B:B;1);"")

Trascina verso il basso sia B1 sia D1

Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Posizione di una variabile nella funzione Piccolo

Postdi tutamimetica » 14/05/12 18:36

Ho risolto da solo.
Questa la soluzione.
Nella colonna A c'erano i numeri
Nella colonna C ho spostato le posizioni dei numeri
Nella colonna B mi sono creato una colonna di aiuto =SE(A1="";"";(A1+C1/10)*10) da trascinare giù
nella colonna D mi sono calcolato i valori più piccoli dal più piccolo al più grande della colonna A con D1=PICCOLO($A$1:$A$150;1) D2==PICCOLO($A$1:$A$150;2) .....
Nella colonna E mi sono calcolato i valori più piccoli dal più piccolo al più grande della colonna B con E1=PICCOLO($B$1:$B$150;1) E2=PICCOLO($B$1:$B$150;2) .....
F1=E1
F2==SE(D2=D1;CERCA.VERT(E2;$B$1:$C$150;2;0);CERCA.VERT(D2;$A$1:$C$150;3;0)
Grazie
tuta
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25

Re: Posizione di una variabile nella funzione Piccolo

Postdi tutamimetica » 14/05/12 18:38

Flash scrivevo mentre te postavi la risposta.
Meglio così. Ci saranno due alternative.
Grazie lo stesso
tuta
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25


Torna a Applicazioni Office Windows


Topic correlati a "Posizione di una variabile nella funzione Piccolo":


Chi c’è in linea

Visitano il forum: Nessuno e 11 ospiti

cron