Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

somma minuti

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

somma minuti

Postdi zuzzumaja » 11/05/12 20:43

salve, ho un programma che mi restituisce una statistica ore con questo formato:
es:
18,50 (18 ore e 50 minuti)
11,20 (11 ore e 20 minuti)

dovrei fare la somma in maniera tale che mi restituisca 30.10 in formato orario ([h].mm)

da quanto ho capito basterebbe cambiare la virgola con il punto e formattare la cella, ma se esiste una formula la preferirei, grazie
zuzzumaja
Utente Junior
 
Post: 65
Iscritto il: 26/08/09 13:34

Sponsor
 

Re: somma minuti

Postdi Zer0Kelvin » 11/05/12 23:31

Ciao.
Non mi è chiaro se nelle celle c'è tutta la stringa "18,50 (18 ore e 50 minuti)" oppure solo "18,50"; presumerò che sia vera la prima ipotesi.
Se esista una formula per farlo direttamente non sò; io ho provato questa soluzione: ipotizzando due valori in A1:A2, una colonna di appoggio nascosta (col. E per esempio) in cui inserisco questa formula:
Codice: Seleziona tutto
=ORARIO.VALORE(SOSTITUISCI(SINISTRA(A1;5);",";":"))
da copiare in basso finchè serve e, nella cella dove vogliamo la somma:
Codice: Seleziona tutto
=SOMMA(E1:E2)
la cella della somma andrà comunque formattata col formato
Codice: Seleziona tutto
 [h]:mm
spero qualcuno abbia una soluzione migliore... :arrow:
[Win7,Office2010]
Condividere la conoscenza aumenta la ricchezza di tutti(Z0°K)
Dai ad un uomo un pesce e lo avrai sfamato per un giorno;insegnagli a pescare e lo avrai sfamato per sempre(Confucio)
Il sonno della ragione genera mostri(Francisco Goya)
Avatar utente
Zer0Kelvin
Utente Senior
 
Post: 303
Iscritto il: 08/04/12 11:23

Re: somma minuti

Postdi CANAPONE » 12/05/12 06:50

Ciao a tutti,

seguo il ragionamento di Zer0Kelvin e con lo stesso formato [hh]:mm impostato nella cella si potrebbe provare anche

Codice: Seleziona tutto
=SOMMA(INDICE(INT(A1:A50)/24;0);INDICE(RESTO(A1:A50;1)*100/24/60;0))


Sperando che gli arrotondamenti che fa la formula non creino problemi.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: somma minuti

Postdi Zer0Kelvin » 12/05/12 12:30

Salve a tutti.
Volevo solo chiarire che la mia formula funziona solo se nelle celle da valutare c'è un testo e non un numero...
Come ho detto all'inizio, non ho capito se le celle contengano solo il valore dell'orario oppure tutta la stringa "18,50 (18 ore e 50 minuti)".
:?: :arrow:
[Win7,Office2010]
Condividere la conoscenza aumenta la ricchezza di tutti(Z0°K)
Dai ad un uomo un pesce e lo avrai sfamato per un giorno;insegnagli a pescare e lo avrai sfamato per sempre(Confucio)
Il sonno della ragione genera mostri(Francisco Goya)
Avatar utente
Zer0Kelvin
Utente Senior
 
Post: 303
Iscritto il: 08/04/12 11:23

Re: somma minuti

Postdi ricky53 » 12/05/12 22:19

Ciao zuzzumaja,
hai avuto modo di verificare quanto ti è stato proposto?
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: somma minuti

Postdi zuzzumaja » 13/05/12 07:04

intanto grazie a tutti, ho risolto con la formula di canapone, sembra che non ci siano problemi con gli arrotondamenti, ringrazio anche Zer0Kelvin, ma non ho possibilita di appoggiarmi su colonne nascoste(p.s. nella cella c'è solo il valore).
zuzzumaja
Utente Junior
 
Post: 65
Iscritto il: 26/08/09 13:34


Torna a Applicazioni Office Windows


Topic correlati a "somma minuti":


Chi c’è in linea

Visitano il forum: Anthony47 e 6 ospiti