Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

formula Excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

formula Excel

Postdi siderone » 23/04/12 16:14

salve,
in Excel come debbo fare per ottenere la somma di 10 numeri di una riga contenente 30 numeri derivanti da formule, escludendo gli zeri (cioè avere la somma algebrica dei soli numeri positivi con quelli negativi)?
siderone
Newbie
 
Post: 3
Iscritto il: 23/04/12 16:04

Sponsor
 

Re: formula Excel

Postdi wallace&gromit » 23/04/12 16:51

ciao siderone,
questa devi spiegarcela meglio:
la somma di 0 da comunque 0 quindi perchè escluderlo?
forse intendevi invece la media?
In questo caso puoi usare:
Codice: Seleziona tutto
=media(se(A1:AD1<>0;A1:AD1)

da confermare con Alt+Maiusc+Enter
assumo che i tuoi 30 dati siano nelle celle da A1 ad AD1.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1419
Iscritto il: 16/01/12 14:21

Re: formula Excel

Postdi ricky53 » 24/04/12 00:39

Ciao Siderone,
benvenuto nel nostro forum.

Spero che quanto ti ha scritto Wallace possa risolvere il tuo quesito.

In caso non sia così ti chiedo la cortesia di scrivere in modo più chiaro le tue esigenze e ... di leggere la mia firma

Grazie per la collaborazione
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: formula Excel

Postdi siderone » 24/04/12 09:33

non avevo scritto che nel mio caso debbo prendere i 10 numeri più grandi e quindi prendere o non prendere lo zero fa cambiare la somma, perchè lo zero me lo somma prima dei numeri negativi, mentre io non voglio che lo zero sia contato nei 10 numeri da sommare.
Più chiaro ora? grazie e saluti
siderone
Newbie
 
Post: 3
Iscritto il: 23/04/12 16:04

Re: formula Excel

Postdi wallace&gromit » 24/04/12 10:00

ciao siderone,
allora è tutto più chiaro.
Intanto ti propongo la mia soluzione con alcune righe d'appoggio, ma i maghi del forum magari riusciranno a condensare il tutto in una singola formula tipo somma.matr.prodotto.
Comunque la mia soluzione è questa:
in A1:AD1 ho i dati.
in A2 inserisco la formula:
Codice: Seleziona tutto
=SE(A1=0;MIN($A1:$AD1);A1)

in A3:
Codice: Seleziona tutto
=SE(RANGO(A2;$A2:$AD2)<11;A2;0)

in A4:
Codice: Seleziona tutto
=SOMMA(A3:H3)


funziona come da te richiesto ma ATTENZIONE agli ex-aequo!
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1419
Iscritto il: 16/01/12 14:21

Re: formula Excel

Postdi Anthony47 » 24/04/12 10:40

Ciao siderone, benvenuto anche da parte mia.
Una formula come questa somma i 10 numeri piu' grandi, escludendo i valori "zero":
Codice: Seleziona tutto
=SOMMA(GRANDE(SE(A1:AD1<>0;A1:AD1;"");RIF.RIGA(INDIRETTO("1:10"))))
da confermare con Contr-Maiusc-Enter

Ciao a tutti
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: formula Excel

Postdi wallace&gromit » 24/04/12 12:11

Eh, la magia pura di Anthony... risolve anche il problema degli ex-aequo!
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1419
Iscritto il: 16/01/12 14:21

Re: formula Excel

Postdi siderone » 24/04/12 13:34

grazie Anthony, tutto risolto
siderone
Newbie
 
Post: 3
Iscritto il: 23/04/12 16:04


Torna a Applicazioni Office Windows


Topic correlati a "formula Excel":


Chi c’è in linea

Visitano il forum: Nessuno e 11 ospiti