Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

difficoltà con excel urgente

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

difficoltà con excel urgente

Postdi pordenonese87 » 10/04/12 21:00

Buonasera a tutti ,
sul nuovo posto di lavoro mi hanno dato un foglio excel da elaborare. Arrivo subito al punto :ci sono dei grafici di dati con due serie: una rappresentata tramite colonna di istogramma con valori reali , la seconda serie invece rappresenta dei valori standard ideali che tagliano l'istogramma con una linea in orizzontale . Il mio obiettivo è far cambiare il colore alla colonna intera dell'istogramma solo quando il valore della serie uno supera la linea della serie 2 ( che rappresenta il valore standard ) . Spero sia possibile in quando per domani dovrei riuscire a completare il lavoro.
Nel file precedente le barre dell'istogramma venivano colorate a mano tramite il riempimento barra per barra .
ringrazio e saluto
pordenonese87
Newbie
 
Post: 2
Iscritto il: 10/04/12 20:44

Sponsor
 

Re: difficoltà con excel urgente

Postdi Flash30005 » 10/04/12 22:24

Ciao Pordenonese e benvenuto nel Forum

Puoi utilizzare due colonne di appoggio e creare il grafico istogramma su queste nuove colonne
Ammettendo che in A ci siano i valori asse X
In B i dati degli istogrammi
In C la linea standard
In D2 inserisci questa formula
Codice: Seleziona tutto
=SE(B2>C2;0;B2)

In E questa formula
Codice: Seleziona tutto
=SE(B2<=C2;0;B2)

Ora trascini (copiando) D2:E2 verso il basso fino dove serve

Poi crei il grafico istogramma delle serie colonna D e E
Puomodificare quello attuale cambiando i riferimenti della colonna B con D e aggiungendo la serie della colonna E

Allego file esempio

Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: difficoltà con excel urgente

Postdi Anthony47 » 11/04/12 16:03

Ciao pordenonese87, benvenuto anche da parte mia.
La proposta di Flash e' molto interessante e ti suggerisco di provarla; si tratta di creare due serie da quella che tu chiami "valori reali", una che contiene i valori reali se inferiori alla soglia e un' altra che contiene i valori reali oltre la soglia, che sul grafico avranno colori diversi.
Il mio suggerimento e' che il grafico che crei sia di tipo "stacked", in modo che vedrai una sola barra, di colore diverso a seconda che quel punto superi o non superi la soglia; come da immagine:
Immagine

Uploaded with ImageShack.us

Una variante e' creare sempre le due serie, di cui la prima "fino al valore di soglia" e la seconda per il valore oltre la soglia; in questo modo il grafico avra' questo aspetto:
Immagine

Uploaded with ImageShack.us

Per questo in D2 la formula sara'
Codice: Seleziona tutto
=SE(B2>C2;C2;B2)
E in E2:
Codice: Seleziona tutto
=MAX(0;B2-C2)

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "difficoltà con excel urgente":

Aiuto urgente!!!
Autore: templare77
Forum: Software Windows
Risposte: 0

Chi c’è in linea

Visitano il forum: Anthony47 e 24 ospiti