Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

EXCEL Formula o funzione per conteggio

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

EXCEL Formula o funzione per conteggio

Postdi Francesco53 » 05/04/12 08:51

Buongiorno a tutto il Forum,
ogni tanto vengo a disturbarvi, ho la seguente necessità:
devo contare quanti numeri sono presenti una sola volta in una riga, allego immagine per chiarezza.

Immagine

Come potete vedere nella cella C6 con Conta.Numeri(F6:AB6), ottengo quanti numeri sono presenti
nella riga, ma di questi, due si ripetono, per cui il risultato non deve essere 21 ma 19.
Spero di essere riuscito a far capire cosa cerco.
Grazie a tutti.
Francesco
S.O. Vista e Office 2007
Francesco53
Utente Senior
 
Post: 647
Iscritto il: 20/02/10 18:45

Sponsor
 

Re: EXCEL Formula o funzione per conteggio

Postdi CANAPONE » 05/04/12 09:41

Ciao, purtroppo non vedo l'immagine.

Prova:

Codice: Seleziona tutto
=SOMMA(INDICE(--(CONTA.SE(F6:AB6;F6:AB6)=1);))


Spero sia d'aiuto.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: EXCEL Formula o funzione per conteggio

Postdi ricky53 » 05/04/12 10:50

Ciao Canapone,
però in questo modo non viene contato nessun numero che è presente almeno due volte ...

Esempio ho dieci colonne (F-O) e scrivo i seguenti numeri 1,2,3,4,5,5,4,3,2,1 (uno per colonna) come risultato si ottiene "zero" invece, a mio avviso, dovrebbe essere "5" ...

Francesco: tu quale risultato ti attendi con i numeri del mio esempio ?
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: EXCEL Formula o funzione per conteggio

Postdi Francesco53 » 05/04/12 11:07

Un saluto a tutti e due, Ricky hai ragione, in base al tuo esempio mi attendo un 5.
Francesco
S.O. Vista e Office 2007
Francesco53
Utente Senior
 
Post: 647
Iscritto il: 20/02/10 18:45

Re: EXCEL Formula o funzione per conteggio

Postdi CANAPONE » 05/04/12 11:12

Ciao

se F6:AB6 non contiene celle vuote, potrebbe bastare

Codice: Seleziona tutto
=SOMMA(INDICE(1/CONTA.SE(F6:AB6;F6:AB6);))


Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: EXCEL Formula o funzione per conteggio

Postdi Francesco53 » 05/04/12 13:05

CIao canapone,
ti ringrazio per i tuoi suggerimenti, purtroppo essendoci delle celle vuote,
il risultato è un #DIV/0! per cui non ho risolto la mia ricerca.
Francesco
S.O. Vista e Office 2007
Francesco53
Utente Senior
 
Post: 647
Iscritto il: 20/02/10 18:45

Re: EXCEL Formula o funzione per conteggio

Postdi CANAPONE » 05/04/12 13:18

Ciao,

ci sono sicuramente soluzioni migliori


Codice: Seleziona tutto
=SOMMA(INDICE((F6:AB6<>"")/CONTA.SE(F6:AB6;F6:AB6&"");))-(CONTA.VUOTE(F6:AF6)>0)



Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: EXCEL Formula o funzione per conteggio

Postdi Francesco53 » 05/04/12 13:28

Ciao canapone e grazie,
la formula da te postata va bene, ho solo dovuto aggiungere il +1 alla fine.
Codice: Seleziona tutto
=SOMMA(INDICE((F6:AB6<>"")/CONTA.SE(F6:AB6;F6:AB6&"");))-(CONTA.VUOTE(F6:AF6)>0)+1

Francesco
S.O. Vista e Office 2007
Francesco53
Utente Senior
 
Post: 647
Iscritto il: 20/02/10 18:45

Re: EXCEL Formula o funzione per conteggio

Postdi CANAPONE » 05/04/12 13:31

Ciao Francesco,

avevo corrotto il range sul quale facevo le prove: forse dei colpi della barra spaziatrice.

Così mi piace di più

Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(($F$6:$AB$6<>"")/CONTA.SE($F$6:$AB$6;$F$6:$AB$6&""))


Sempre che funzioni

Saluti


Excusatio non petita, culpa manifesta
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: EXCEL Formula o funzione per conteggio

Postdi ricky53 » 05/04/12 13:51

Ciao,
mi sembra che sia O.K. ... attendiamo la conferma di Francesco.

Scusa Canapone perchè ha utilizzato [code]&""[code] nel "CONTA.SE" ???
Anche senza il risultato mi sembra sia corretto.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: EXCEL Formula o funzione per conteggio

Postdi CANAPONE » 05/04/12 14:22

Ciao Ricky53,

ho aggiunto &"" per far rientrare nel conteggio anche le celle vuote.

Se levi &"" come parametro da far contare al conta.se, appena trova una cella vuota piazza uno 0 fra i numeri che saranno considerati come denominatore.
Lo 0 - basta una cella vuota- produce l'errore #DIV/0! che segnalava Francesco.

Se facciamo contare anche le celle vuote a denominatore, otteniamo un numero che sarà comunque non considerato dalla matrice di vero o falso che si forma a numeratore grazie a

($F$6:$AB$6<>"")

Faccio un piccolo esempio su un intervallo di 7 celle

1/ vuota/ 1 /vuota/ 2/ 3/ 1

3 numeri diversi su 7 spazi

la formula a numeratore scrive per il meccanismo del vero falso

1 0 1 0 1 1 1

a denominatore conta ogni volta i numeri e le celle vuote

3 2 3 2 1 1 3

3 volte il numero 1 - 2 volte la cella vuota - 1 volta il 2- 1 volta il 3

La formula produce infine una somma di divisioni

=matr.somma.prodotto(1/3+0/2+1/3+0/2+1/1+1/1+1/3)

e restituisce 3


Mi spiace non saper usare una terminologia forse più appropriata.

Saluti













Il conta.se vede -esempio- 3 e 3&"" come lo stesso numero.
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: EXCEL Formula o funzione per conteggio

Postdi Francesco53 » 05/04/12 14:57

Perfetto, grazie
Francesco
S.O. Vista e Office 2007
Francesco53
Utente Senior
 
Post: 647
Iscritto il: 20/02/10 18:45

Re: EXCEL Formula o funzione per conteggio

Postdi ricky53 » 05/04/12 15:11

Ciao Canapone,
ottimo.
Nelle prove che ho fatto mi era sfuggita questa eventualità.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia


Torna a Applicazioni Office Windows


Topic correlati a "EXCEL Formula o funzione per conteggio":


Chi c’è in linea

Visitano il forum: Marius44, raimea e 13 ospiti