Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Calcolare la percentuale di differenza in una colonna prezzi

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Calcolare la percentuale di differenza in una colonna prezzi

Postdi fantina » 03/04/12 15:37

:)
:)
:)
vi sono mancata?? :D

Nel mio foglio excel ho un elenco di prodotti, contraddistinti nella colonna A dal loro codice prodotto, un normalissimo numero di cinque cifre. I codici sono ordinati in maniera crescente, possono ripetersi e quindi essere presenti svariate righe dello stesso codice nel caso in cui il prezzo fosse variato durante l'anno. Nella colonna H sono indicati i prezzi. Vorrei cortesemente :roll: il vostro aiuto per ottenere ad ogni cambio di codice un valore in percentuale tra il primo prezzo e l'ultimo del "gruppetto", per ottenere l'informazione di quanto lo stesso prodotto è aumentato nel tempo.
Spero di essere stata chiara....
Grazie! :)
fantina
Utente Senior
 
Post: 476
Iscritto il: 05/03/07 15:24

Sponsor
 

Re: Calcolare la percentuale di differenza in una colonna pr

Postdi wallace&gromit » 03/04/12 20:15

Ciao Fantina,
intanto ti propongo questa formula (è un po' contorta ma funziona).
Codice: Seleziona tutto
=H2/INDIRETTO("h"&SE(A2<>A1;RIF.RIGA();(CONFRONTA(A2;$A$1:$A$18;0))))-1

inseriscila per esempio in I2 e copiala in giù, presuppone che la lista dei codici inizi in A2, con un'intestazione di riga in A1.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: Calcolare la percentuale di differenza in una colonna pr

Postdi CANAPONE » 04/04/12 03:44

Ciao a tutti,

un altro modo potrebbe essere

Codice: Seleziona tutto
=se(A3=A2;"";H2/cerca.vert(A2;A$2:H2;8;0)-1)


copi la formula accanto al primo codice (in A2 nell'esempio) e la tiri giù.

Spero sia d'aiuto


http://wikisend.com/download/268910/variazione.xls
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Calcolare la percentuale di differenza in una colonna pr

Postdi fantina » 04/04/12 13:07

Grazie! Funzionano tutt'e due. In quella di wallace ho dovuto solo allungare da 18 a 600 l'intervallo delle righe della formula, quella di canapone posso usarla sia con il SE per avere il risultato sintetico sia senza per averlo su tutte le righe. Bellissime! Mi ha anche molto attizzato l'uso del Cerca Verticale per delimitare il gruppo. Grazie mille a entrambi, ma voglio complicarvi di più la vita: nella colonna J ora voglio aggiungere il conto in giorni tra la data del primo prezzo e l'ultimo del medesimo articolo; queste date sono nella colonna C e sono in ordine crescente per ogni gruppetto codici. Il risultato che voglio ottenere ad esempio è: il codice AAAA è cambiato del 10% in 365 giorni mentre il codice BBB è cambiato del 10% in 180 giorni... e così via....

:)
fantina
Utente Senior
 
Post: 476
Iscritto il: 05/03/07 15:24

Re: Calcolare la percentuale di differenza in una colonna pr

Postdi CANAPONE » 04/04/12 13:24

Ciao, grazie del simpatico riscontro.

Nell'esempio nella colonna C le date: uso lo stesso sistema, il cerca.vert cerca la prima data corrispondente al codice.

in K2 (accanto alla colonna delle date):

Codice: Seleziona tutto
=SE($A3=$A2;"";C2-CERCA.VERT($A2;$A$2:$J2;3;0))


oppure (dipende come calcoli la differenza)

Codice: Seleziona tutto
=SE($A3=$A2;"";C2-CERCA.VERT($A2;$A$2:$J2;3;0)-1)


La colonna K deve essere formattata come numero.

-----------------------
Edit nella colonna C le date: cerca.vert pesca al terzo posto.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze


Torna a Applicazioni Office Windows


Topic correlati a "Calcolare la percentuale di differenza in una colonna prezzi":


Chi c’è in linea

Visitano il forum: enrico43 e 13 ospiti