Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel2003: conta.se nel periodo tra due date

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

excel2003: conta.se nel periodo tra due date

Postdi karug64 » 22/03/12 21:46

Salve a tutti.
Nel mio foglio ho in A1 e A2 due campi data ("da data" - "a data").
In colonna "D" ho la data, in colonna "C" posso avere il valore "TRA" o "EXT"
In cella B1 dovrei contare quante volte e' presente il valore "TRA" nella colonna "C" nell'intervallo specificato dalle due date indicate in A1 e A2 (possibilmente senza l'uso di vba).
Quindi se A1 = 01/02/2012 e A2 = 28/02/2012
in C e D
TRA-02/01/2012
EXT-04/01/2012
EXT-05/01/2012
TRA-10/01/2012
TRA-20/01/2012
TRA-29/01/2012
EXT-01/02/2012
TRA-02/02/2012
TRA-03/02/2012
EXT-10/02/2012
TRA-15/02/2012
in B1 dovrei avere 3

Grazie
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Sponsor
 

Re: excel2003: conta.se nel periodo tra due date

Postdi Anthony47 » 22/03/12 21:57

Prova con
Codice: Seleziona tutto
=SOMMA((C1:C100="TRA")*(D1:D100>=A1)*(D1:D100<=A2))
Da confermare con Contr-Maiusc-Enter
Se pensi di avere piu' di 100 righe modifica quei tre "100".

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel2003: conta.se nel periodo tra due date

Postdi karug64 » 22/03/12 22:04

Grazie.
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22


Torna a Applicazioni Office Windows


Topic correlati a "excel2003: conta.se nel periodo tra due date":


Chi c’è in linea

Visitano il forum: Nessuno e 27 ospiti