Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Somma

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Somma

Postdi danliz » 17/02/12 20:41

Salve, mi serve un metodo (possibilmente con macro) per sommare velocemente con excel dei dati corrispondenti a delle date come qui sotto:

03/01/1996 04/01/19960 5/01/1996 08/01/1996 09/01/1996 10/01/1996 11/01/1996....

austria 487,03 494,75 500,63 499,92 504,74 500,04 500,24 .....
belgio 503,54 501,02 0,012458453 0,015726862 0,011814721 -0,00141922 0,0095 .....
germania -0,00935535 0,000399888 0,00657517 -0,005017132 ...............

Siccome le date sono molte e anche i valori sotto di esse, mi serve un metodo per fare la somma di una stessa riga (in questo caso 487,03+494,75+500,63+499,92+504,74+500,24... per il caso dell' austria) partendo dal 3/01/1996 fino al 3/01/2000 ad esempio. Quindi cambiando il periodo di riferimento e il paese mi deve calcolare di volta in volta il valore della somma. Grazie
danliz
Utente Junior
 
Post: 18
Iscritto il: 23/11/11 11:09

Sponsor
 

Re: Somma

Postdi ricky53 » 17/02/12 20:51

Ciao
i dati per riga sono tutti in celle distinte?
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Somma

Postdi wallace&gromit » 17/02/12 21:51

ciao danliz,
mentre Ricky rimugina ti propongo una formula invece di una macro, guarda se può andarti bene.
Assumo che i dati siano in foglio 1
a1 è vuota
da a2 in giù ci sono i riferimenti alle nazioni
da b1 a destra ci sono le date
i valori si trovano da b2 via

sul foglio 2 inserisco
in a1 la nazione
in b1 la data di inizio
in c1 la data di fine (volendo si può farle calcolare esattamente 3 anni dalla data di inizio però è importante che entrambe le date figurino effettivamente nell'elenco del foglio 1)

in a2 inserisco la formula:
Codice: Seleziona tutto
=SOMMA(SCARTO(Foglio1!A1;CONFRONTA(A1;Foglio1!A2:A20);CONFRONTA(B1;Foglio1!B1:GZ1);1;CONFRONTA(C1;Foglio1!B1:GZ1)+1-CONFRONTA(B1;Foglio1!B1:GZ1)))

che mi da il valore cercato.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1419
Iscritto il: 16/01/12 14:21

Re: Somma

Postdi danliz » 18/02/12 09:38

Purtroppo ho provato ma non mi ha dato alcun esito...ovviamente ogni dato sta in una cella differente.SE qualcuno mi sa proporre una macro è meglio così mi facilito le cose.
danliz
Utente Junior
 
Post: 18
Iscritto il: 23/11/11 11:09

Re: Somma

Postdi danliz » 18/02/12 10:05

Io l'ho provata ad impostare così con un contatore, non mi dice che c'è un errore ma non riesco a visualizzare il risultato. Voi che ne pensate?
Sub somma()
Dim data As Date
Dim austria As Double
Dim somma As Double
Dim risultato As Double
Dim valore As Double
For data = 4 / 6 / 1999 To 4 / 6 / 2000
valore = austria
somma = valore + risultato
risultato = valore + somma
Next data
risultato = risultato
End Sub

quello è un'esempio di parte di dati di cui fare la somma dal 4/6/1999 al 4/6/2000 inerente all'austria.
danliz
Utente Junior
 
Post: 18
Iscritto il: 23/11/11 11:09

Re: Somma

Postdi Anthony47 » 18/02/12 12:34

Personalmente per poter dare un contributo avrei bisogno di sapere esattamente quale e' la tua struttura dati, che al momento non l' ho capito.
Se e' una cosa semplice (mi pare che sia cosi') dovrebbe bastare uno screenshot; vedi qui per come fare: viewtopic.php?f=26&t=80395#p466013

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Somma

Postdi danliz » 18/02/12 13:29

Ok ti mando lo screenshot. Io devo fare la somma di quei rendimenti considerando periodi diversi.
Es:
prendere per l'austria rendimenti che vanno dal 1/1/2000 al 1/1/2005 facendone la somma. Ovviamente questo lo dovrò fare per differenti intervalli temporali e per paesi differenti. Immagine
danliz
Utente Junior
 
Post: 18
Iscritto il: 23/11/11 11:09

Re: Somma

Postdi danliz » 18/02/12 13:30

Scusa ho sbagliato, questo link va :Immagine
danliz
Utente Junior
 
Post: 18
Iscritto il: 23/11/11 11:09

Re: Somma

Postdi Anthony47 » 18/02/12 15:28

Non e' chiaro perche' vuoi farlo con macro; fatto con formula:
-in Foglio3!A2 indichi il Paese
-in Foglio3!A3 indichi la data di inizio
-in Foglio3!A4 la data di fine
Poi in una cella di Foglio3 usi la formula
Codice: Seleziona tutto
=SOMMA(SCARTO(Foglio2!A1;CONFRONTA("Indice "&A2;Foglio2!A:A;0);CONFRONTA(A3;Foglio2!1:1)-1;1;CONFRONTA(A4;Foglio2!1:1)-CONFRONTA(A3;Foglio2!1:1)+1))


Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Somma":


Chi c’è in linea

Visitano il forum: Nessuno e 13 ospiti