Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Minimo di valori assoluti

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Minimo di valori assoluti

Postdi -serena- » 01/01/12 05:22

Salve a tutti, ho bisogno di un piccolo aiuto.
Ho in colonna A dei numeri positivi e negativi ottenuti come differenza di altri valori.
Devo:
- calcolare il minimo dei valori in colonna A che deve essere positivo
- contare quanti valori della colonna A sono uguali al minimo.

1- ho individuato subito ad occhio i valori di colonna A che corrispondono al minimo: 0.05 e -0.05
2- In colonna B calcolo il valore assoluto dei valori in colonna A con =ASS(A1), =ASS(A2), ..
3- In colonna C calcolo il minimo =MIN(B1:B12) e ottengo 0.05
4- In colonna D calcolo =B1-0.05, B2-0.05, ..
4- quando calcolo =CONTA.SE(D1:D12;"=0") invece di ottenere il valore 2 ottengo 1
Dove sbaglio? :-?
Grazie in anticipo e buon anno
-serena-
Newbie
 
Post: 3
Iscritto il: 01/01/12 04:34

Sponsor
 

Re: [Excel] Minimo di valori assoluti

Postdi Flash30005 » 01/01/12 14:38

Ciao Serena e benvenuto/a nel Forum

Lasciando la colonna A con i dati e senza creare altre colonne di appoggio inserisci questa formula nella cella B1:
Codice: Seleziona tutto
=CONTA.SE(A1:A12;MIN(A1:A12))+CONTA.SE(A1:A12;ASS(MIN(A1:A12)))


Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: [Excel] Minimo di valori assoluti

Postdi -serena- » 01/01/12 16:04

Ciao Flash, grazie per l'aiuto ma, purtroppo, continua a dare come risultato 1 invece che 2.
In qualunque modo rendo positivo -0.05 (=ass(.....) o =RADQ(POTENZA(...;2))) comunque =CONTA.SE lo considera negativo e quindi l'unico minimo.
-serena-
Newbie
 
Post: 3
Iscritto il: 01/01/12 04:34

Re: [Excel] Minimo di valori assoluti

Postdi -serena- » 01/01/12 19:17

Ciao Flash,
la tua formula funziona alla perfezione se la applico al max tra il numero in colonna A e il suo opposto.
Grazie :)
-serena-
Newbie
 
Post: 3
Iscritto il: 01/01/12 04:34

Re: [Excel] Minimo di valori assoluti

Postdi Anthony47 » 01/01/12 21:53

Ottimo l' uso di colonne intermedie per arrivare la risultato che serve. Lo stesso risultato poltrebbe essere ottenuto con formule a matrice, ad es. per il minimo:
Codice: Seleziona tutto
=MIN(ASS(A1:A12))

per il conteggio:
Codice: Seleziona tutto
 =SOMMA(--(ASS(A1:A12)=MIN(ASS(A1:A12))))

Ambedue le formule sono da confermare con Contr-Maiusc-Enter (non col solo Enter)

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Minimo di valori assoluti":


Chi c’è in linea

Visitano il forum: alfrimpa e 19 ospiti