Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] MATR:SOMMA.PRODOTTO(): cella vuota o zero?

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] MATR:SOMMA.PRODOTTO(): cella vuota o zero?

Postdi EmilioOo » 31/10/11 12:48

Ciao ragazzi,

vado subito al dunque del mio problema: ho una colonna di numeri alternati a celle vuote (D4:D57) e devo sommare solo i 20 più alti di questi valori.

Ho provato con la formula

Codice: Seleziona tutto
MATR.SOMMA.PRODOTTO(RANGO(D4:D57;D4:D57;0)<=20;D4:D57)

la quale peraltro funziona in OpenOffice, ma in excel mi da un errore.
Anche la variante:

Codice: Seleziona tutto
MATR.SOMMA.PRODOTTO((RANGO(D4:D57;D4:D57;0)<=20)*D4:D57)

che in passato mi ha incomprensibilmente (per me) risolto qualche errore, in questo caso non funziona.

Il problema, per quanto ho capito, è dovuto al fatto che i dati nell'intervallo (D4:D57) sono prelevati da un altro foglio con la formula:

Codice: Seleziona tutto
SE($Calcoli.H4="";"";$Calcoli.H4)

copiata ovviamente in tutte le celle dell'elenco, per cui le celle "vuote" del mio intervallo non vengono in realtà interpretate come vuote dalla funzione, poiche' vi e' in effetti una formula. D'altra parte la soluzione di valorizzare a zero le celle vuote non e' percorribile, poiche' mi serve distinguere il caso di valore nullo dal caso di cella vuota (devo poi fare delle considerazioni sul valore medio).

Due ulteriori precisazioni: dal momento che voglio mantenere la compatibilità con OpenOffice:
1) non vorrei ricorrere al VBA (sarebbe troppo facile)
2) non posso usare questa alternativa:

Codice: Seleziona tutto
=SE(D61>20;SOMMA(GRANDE((D4:D58);{1.2.3.4.5.6.7.8.9.10.11.12.13.14.15.16.17.18.19.20}));SOMMA(D4:D58))

che mi e' stata suggerita ed effettivamente funziona in Excel, ma non in OpenOffice.

Sono molto curioso di sentire i vostri pareri!
Grazie anticipatamente, ciao
Emilio
EmilioOo
Newbie
 
Post: 5
Iscritto il: 31/10/11 12:27

Sponsor
 

Re: [Excel] MATR:SOMMA.PRODOTTO(): cella vuota o zero?

Postdi EmilioOo » 31/10/11 15:02

Dalle prove che sto continuando a fare, sembra che il problema sia della funzione RANGO() che mal digerisce del testo fra gli argomenti, piuttosto che della MATR.SOMMA.PRODOTTO()...

Ho pensato all'uso di NUM(), per convertire le celle "" in valori nulli, ma se per la singola cella funziona, mi da' errore se la applico a un intervallo cosi':
Codice: Seleziona tutto
NUM(D4:D57)


Ho anche cercato di fare un somma... se... con gli array {...}, ma invano.

Any suggestions?
EmilioOo
Newbie
 
Post: 5
Iscritto il: 31/10/11 12:27

Re: [Excel] MATR:SOMMA.PRODOTTO(): cella vuota o zero?

Postdi CANAPONE » 31/10/11 15:05

Ciao, vado un po' alla cieca non avendo open office:spero accetti formule matriciali.

Prova:

=MATR.SOMMA.PRODOTTO(GRANDE(D4:D58;RIF.RIGA(A1:A20)))

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [Excel] MATR:SOMMA.PRODOTTO(): cella vuota o zero?

Postdi EmilioOo » 31/10/11 15:15

Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(GRANDE(D4:D58;RIF.RIGA(A1:A20)))

Scusa Canapone, ma questa non la capisco, non funziona nemmeno in Excel...
ciao
EmilioOo
Newbie
 
Post: 5
Iscritto il: 31/10/11 12:27

Re: [Excel] MATR:SOMMA.PRODOTTO(): cella vuota o zero?

Postdi CANAPONE » 31/10/11 15:33

Ciao,

la formula somma i 20 valori più alti che trova nell'intervallo D4:D58: mi spiace non avere la possibilità dove ti sto scrivendo nè di condividerti il file dove ho controllato la risposta della formula, nè di poter scaricare documenti da siti di filesharing.

Forse non ho capito: la formula risponde con qualche tipo di errore?

Saluti

Edit: ho provato la formula su Calc di Open Office di un collega (che ringrazio). La formula mi restituisce lo stesso valore.
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [Excel] MATR:SOMMA.PRODOTTO(): cella vuota o zero?

Postdi EmilioOo » 31/10/11 15:48

Funziona ma non risolve il problema.
Ovvero, funziona solo se nel range di valori ci sono solo numeri o celle vuote. Non funziona nel caso che interessa a me, ovvero se nel renge di valori ci sono anche delle funzioni che ritornano il valore "". In quest'ultimo caso mi da' errore #NUM!

Grazie, ciao
EmilioOo
Newbie
 
Post: 5
Iscritto il: 31/10/11 12:27

Re: [Excel] MATR:SOMMA.PRODOTTO(): cella vuota o zero?

Postdi CANAPONE » 31/10/11 16:01

Ciao,

credo l'errore sia prodotto non dai SE e dagli "", ma dal fatto che non ci sono 20 numeri da sommare: prova a nidificare la formula

=SE(CONTA.SE(D4:D58;">0")<20;"";MATR.SOMMA.PRODOTTO(GRANDE(D4:D58;RIF.RIGA(A1:A20)))



Puoi adattare la formula alle tue esigenze: la somma si attiva solo in presenza di almeno 20 valori superiori a 0.

Senza questa condizione la formula produrrebbe #num! (#valore! su OO).

Spero sia d'aiuto
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [Excel] MATR:SOMMA.PRODOTTO(): cella vuota o zero?

Postdi CANAPONE » 31/10/11 16:41

Ciao,


se ti sei trovato bene con la formula in Oper Office

Codice: Seleziona tutto
=SE(D61>20;SOMMA(GRANDE((D4:D58);{1.2.3.4.5.6.7.8.9.10.11.12.13.14.15.16.17.18.19.20}));SOMMA(D4:D58))


basta sostituire i punti con dei punti e virgola su Excel

Codice: Seleziona tutto
=SE(D61>20;SOMMA(GRANDE((D4:D58);{1;2;3;4;5;6;7;8;9;10;11;12;13;14;15;16;17;18;19;20}));SOMMA(D4:D58))


equivalente a quest'ultime (escludo gli zeri, ma puoi facilmente modificare o sostituire il conta.se)

Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(GRANDE(D4:D58;RIF.RIGA(INDIRETTO("1:"&MIN(20;CONTA.SE(D4:D58;">0"))))))


La formula è stata digerita anche da Open Office.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [Excel] MATR:SOMMA.PRODOTTO(): cella vuota o zero?

Postdi EmilioOo » 31/10/11 18:12

Con questa

Codice: Seleziona tutto
=SE(CONTA.SE(D4:D58;">0")<20;"";MATR.SOMMA.PRODOTTO(GRANDE(D4:D58;RIF.RIGA(A1:A20)))

ho risolto, appena avrò un attimo di tempo valuterò gli altri suggerimenti.

Grazie 1000!
ciao
EmilioOo
Newbie
 
Post: 5
Iscritto il: 31/10/11 12:27


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] MATR:SOMMA.PRODOTTO(): cella vuota o zero?":


Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti