Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Somma solo numeri

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Somma solo numeri

Postdi Cedamido » 17/10/11 09:10

In excel 2003 cella B3 Kg. 100 cella B4 Kg. 500, vorrei ottenere la somma dei soli numeri.
Grazie
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Sponsor
 

Re: Somma solo numeri

Postdi Statix » 17/10/11 10:28

Ciao Cedamido,
per le celle dove hai i valori espressi in Kg,potresti usare il Formato celle,personalizzato e scrivere
Codice: Seleziona tutto
0 K\g

cosi metti solo i valori 500 o 100 e vedrai che funziona.
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Somma solo numeri

Postdi Anthony47 » 17/10/11 11:14

Col suggerimento di Statix (vedi sopra) puoi evitare di "scrivere" Kg.500, potendo cioe' scrivere il solo 500 ma visualizzando Kg. 500.
Se invece hai gia' i dati in quel formato, allora potresti usare una formula tipo
Codice: Seleziona tutto
=SOMMA(SE(VAL.ERRORE(VALORE(SOSTITUISCI(B1:B10;"kg.";"")));0;VALORE(SOSTITUISCI(B1:B10;"kg.";""))))
da confermare con Contr-Maiusc-Enter
Questa somma i dati compresi in B1:B10

Oppure usi una colonna di appoggio dove calcoli il valore estratto dalla singola cella; ad esempio questa formula "lavora" sul contenuto di B3:
Codice: Seleziona tutto
=SE(VAL.ERRORE(VALORE(SOSTITUISCI(B3;"kg.";"")));"";VALORE(SOSTITUISCI(B3;"kg.";"")))
Poi puoi usare le formule con il "+" o la funzione "Somma". Il vantaggio della colonna di appoggio e' che si vede il valore convertito, quindi se ci sono errori di conversione (ad esempio perche' nella cella sorgente c' e' scritto "Kg 500" invece di "Kg. 500") te ne puoi accorgere facilmente.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Somma solo numeri

Postdi Cedamido » 17/10/11 21:16

=SOMMA(SE(VAL.ERRORE(VALORE(SOSTITUISCI(B1:B10;"kg.";"")));0;VALORE(SOSTITUISCI(B1:B10;"kg.";""))))
La formula non somma, nella cella B11 appare zero anche dopo aver confermato con ctrl-maiusc-invio, non appaiano le parentesi graffe, dove li devo inserire.
Grazie
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Re: Somma solo numeri

Postdi Statix » 17/10/11 21:30

Per confermare con Ctrl-Maisc-Invio ,la formula la devi selezionare nella barra.
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Somma solo numeri

Postdi Anthony47 » 19/10/11 01:33

Confermo quanto gia' scritto da Statix: scrivi la formula nella barra della formula, quando e' pronta premi Contr, poi Maiusc, poi Invia, poi rilasci tutti i tasti.
Se la formula l' hai gia' scritta, seleziona la cella, F2 (edita formula), premi Contr-Maiusc-Invio.

Vedrai le parentesi graffe attorno alla formula solo se la formula e' stata inserita con la corretta procedura; inserirle da tastiera non fa per niente lo stesso effetto.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Somma solo numeri":


Chi c’è in linea

Visitano il forum: Nessuno e 16 ospiti