Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Conta.Più.Se con operazione

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Conta.Più.Se con operazione

Postdi Sotomayor » 14/10/11 13:43

Salve :)
Ho lasciato da troppo tempo Excel e non riesco venire a capo a questo problema :-?

Esempio tabella:

Codice: Seleziona tutto
| ElencoA | ElencoB | DatoA | DatoB |


La formula deve effettuare queste operazioni: SE in ElencoA oppure in ElencoB è presente X allora deve verificare SE DatoA+DatoB=Y (Y è un numero NON variabile) allora conta.

Pensavo il Conta.Più.Se facesse al caso mio ma non so come verificare la seconda condizione perchè inserendo come Intervallo_criteri_2 le colonne DatoA e DatoB non some come effettuarne la somma riga per riga.

Inserisco un esempio pratico:

Codice: Seleziona tutto
| ElencoA | ElencoB | DatoA | DatoB |
|  Nome1  |  Nome2  |   7   |   3   |
|  Nome3  |  Nome4  |   2   |   4   |
|  Nome3  |  Nome1  |   3   |   0   |
|  Nome4  |  Nome2  |   1   |   1   |
 


Ecco la formula dovrebbe individuare le righe in cui è presente Nome1 e se presente e la somma dei numeri in DatoA e DatoB è maggiore di 5 allora contarla (in tal caso darebbe 1).

C'è un modo per fare ciò senza utilizzare una cella di appoggio in cui inserire il totale di DatoA e DatoB?


Grazie :)
Sotomayor
Newbie
 
Post: 3
Iscritto il: 14/10/11 13:18

Sponsor
 

Re: [Excel] Conta.Più.Se con operazione

Postdi Anthony47 » 14/10/11 14:09

Ciao sotomayor, benvenuto nel forum.
Se i tuoi dati sono in col A:D, riga 2:100, allora puoi usare una formula come questa:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO((A2:A100=F1)+(B2:B100=F1);--((C2:C100+D2:D100)>G1))

Metti in F1 il filtro del Nome e in G1 il filtro del valore.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Conta.Più.Se con operazione

Postdi Sotomayor » 14/10/11 14:27

Anthony47 ha scritto:Ciao sotomayor, benvenuto nel forum.
Se i tuoi dati sono in col A:D, riga 2:100, allora puoi usare una formula come questa:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO((A2:A100=F1)+(B2:B100=F1);--((C2:C100+D2:D100)>G1))

Metti in F1 il filtro del Nome e in G1 il filtro del valore.

Ciao


Ecco cosa mi mancava, le funzioni con le matrici :-?

Grazie per il benvenuto e per l'aiuto :)
Sotomayor
Newbie
 
Post: 3
Iscritto il: 14/10/11 13:18

Re: [Excel] Conta.Più.Se con operazione

Postdi Sotomayor » 14/10/11 15:36

Neanche il tempo di sistemare che , per semplificare altri calcoli, ho la necessità di complicare la formula :D

In pratica vorrei poter fermare il conteggio dopo TOT occorrenze di Nome1 (come nell'esempio), concettualmente ho capito come, è la traduzione (se possibile sempre) in formula Excel che non riesco proprio a vederla.

Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO((A2:A100=F1)+(B2:B100=F1);--((C2:C100+D2:D100)>G1))


In pratica dovrei aggiungere una terza matrice che da VERO finchè non ha incontrato per TOT volte "Nome1" nella colonna "ElencoA" ed "ElencoB".
E' possibile una risoluzione?


P.S. guide/link utili per l'utilizzo delle matrici in Excel?



Grazie anticipatamente :)
Sotomayor
Newbie
 
Post: 3
Iscritto il: 14/10/11 13:18


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Conta.Più.Se con operazione":


Chi c’è in linea

Visitano il forum: Nessuno e 11 ospiti