Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Somma dei primi n valori

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Somma dei primi n valori

Postdi marco883 » 10/10/11 17:39

Ciao a tutti, mi sono iscritto oggi e dopo alcuni giorni che consulto il sito vi chiedo un aiuto su Excel:

Colonna a: data in formato gg/mm/aaaa
Colonna b: numero pezzi prodotti per giorno

Sto cercando una macro che mi consenta di fare la somma cumulativa dei pezzi prodotti fino alla data x.

Es. se imposto x= 10/01/2011, somma le prime dieci celle della colonna b.

Grazie mille e spero in futuro di ricambiare :) .
marco883
Newbie
 
Post: 3
Iscritto il: 10/10/11 17:18

Sponsor
 

Re: [Excel] Somma dei primi n valori

Postdi Anthony47 » 10/10/11 20:05

Ciao, benvenuto nel forum.
Per quello che chiedi non serve una macro, basta una formula. Esempio:
-date sono in col A, le quantita' in col B
-metti in D1 la "Data limite"
-poi usi la formula
Codice: Seleziona tutto
=SOMMA.SE(A:A;"<="&D1;B:B)

In questo modo sommerai tutte le quantita' che hanno in col A una data inferiore o uguale a quella impostata in D1.
D1 e col A devono contenere date in formato excel.

Se pensi di dover mettere anche una data minima, ad es in C1, allora potresti usare la formula
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(A1:A3000>=C1);--(A1:A3000<=D1);B1:B3000)

Questa somma tutte le quantita' che hanno una data superiore o uguale a quella impostata in C1 e inferiore o uguale a quella in D1.
Se pensi che l' elenco vada oltre 3000 aggiorna in modo omogeneo la formula.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Somma dei primi n valori

Postdi marco883 » 11/10/11 06:49

Grazie Anthony47, molto gentile.
marco883
Newbie
 
Post: 3
Iscritto il: 10/10/11 17:18


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Somma dei primi n valori":


Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti