Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Moltiplicazione con comparazione celle

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Moltiplicazione con comparazione celle

Postdi chicolocox21 » 30/09/11 09:16

Ciao a tutti
avrei bisogno di inserire in una cella (mettiamo b2) una macro che gli dice
se la cella P2
è uguale a j2 moltiplica c2*d2 -
se uguale a K2 moltiplica C2*E2 -
se uguale a L2 moltiplica C2*F2 -
se uguale a M2 moltiplica C2*G2
se uguale a N2 moltiplica C2*H2
ho provato con la funzione se ma mi da solo la possibilità di vero o falso
grazie ciao Renato
windows 7 - office 2013
Avatar utente
chicolocox21
Utente Junior
 
Post: 38
Iscritto il: 16/02/07 11:34
Località: MILANO

Sponsor
 

Re: Moltiplicazione con comparazione celle

Postdi Francesco53 » 30/09/11 10:34

Ciao chicolocox,
se i valori delle celle da J2 a N2 sono tutti differenti, puoi inserire nella cella B2
la seguente formula:
Codice: Seleziona tutto
=SE(P2=J2;C2*D2;SE(P2=I2;C2*E2;SE(P2=L2;C2*F2;SE(P2=M2;C2*G2;SE(P2=N2;C2*H2;0)))))


Prova se è quanto cerchi.
Francesco
S.O. Vista e Office 2007
Francesco53
Utente Senior
 
Post: 647
Iscritto il: 20/02/10 18:45

Re: Moltiplicazione con comparazione celle

Postdi Anthony47 » 30/09/11 13:56

La formula di Francesco e' corretta e funzionante; una possibile alternativa potrebbe essere la formula
Codice: Seleziona tutto
=(P2=J2)*C2*D2+(P2=I2)*C2*E2+(P2=L2)*C2*F2+(P2=M2)*C2*G2+(P2=N2)*C2*H2

Con l' avvertenza che qualora P2 fosse per ipotesi uguale sia a J2 che I2, questa formula restituisce la somma di ambedue le motiplicazioni mentre la formula dei SE restituisce solo la prima.
La formula con i SE, d' altra parte, non consente (con XL2003 o inferiori) piu' di 7 "annidamenti", mentre una formula come quella suggerita sopra puo' continuare quasi ad oltranza.

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Moltiplicazione con comparazione celle

Postdi chicolocox21 » 03/10/11 07:51

Grazie a tutti
ho utilizzato la formula di Francesco53 e funziona perfettamente :) :lol: :lol:
windows 7 - office 2013
Avatar utente
chicolocox21
Utente Junior
 
Post: 38
Iscritto il: 16/02/07 11:34
Località: MILANO


Torna a Applicazioni Office Windows


Topic correlati a "Moltiplicazione con comparazione celle":


Chi c’è in linea

Visitano il forum: fabrizio2001 e 12 ospiti