Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel 2007 : problemi con una somma

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel 2007 : problemi con una somma

Postdi mariom » 29/09/11 20:27

Salve a tutti

Il problema è questo :
Devo eseguire una somma di più caselle che sono nella stessa colonna, i valori che sono nelle caselle sono il risultato di "cerca.vert" ma quando in una casella non c'è il valore, la somma non viene fatta.
Esiste un metodo per fargli sommare solo le caselle che hanno dei valori ?
Un grazie in anticipo a chi potrà agliutarmi a risolvere il problema
Avatar utente
mariom
Utente Senior
 
Post: 135
Iscritto il: 31/12/09 17:30

Sponsor
 

Re: Excel 2007 : problemi con una somma

Postdi Flash30005 » 29/09/11 23:11

Non è ben specificato cosa hai nelle celle con formula cerca.verticale
ma se usi un Se(cerca.verticale(etc etc)diverso da errore; Cerca.verticale(etc etc); condizione 0)
dovresti risolvere

senza altri dettagli non riesco a dare ulteriori suggerimenti

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel 2007 : problemi con una somma

Postdi mariom » 30/09/11 12:03

Salve a tutti
La stringa che c'è nelle celle per la somma è la seguente :
=CERCA.VERT($A4;Costo!$C$3:$AD$141; 28; FALSO)
Avatar utente
mariom
Utente Senior
 
Post: 135
Iscritto il: 31/12/09 17:30

Re: Excel 2007 : problemi con una somma

Postdi Statix » 30/09/11 12:26

Ciao mariom,
secondo me,basta mettere nelle formule del cerca.vert
=SE.ERRORE(CERCA.VERT($A4;Costo!$C$3:$AD$141; 28; FALSO);"")
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Excel 2007 : problemi con una somma

Postdi Anthony47 » 30/09/11 13:50

Per rendere meno ambigua la tua richiesta avresti dovuto spiegare che hai un problema quando il Cerca.Vert ti restituisce l' erroe #N/D...
Come detto da Flash e da Statix, la soluzione e' mettere la tua formula all' interno di un "SE"; userai la formula di Statix se hai XL2007 o 2010, oppure quella di Flash se hai Xl2003 o inferiore: =SE(Val.errore(LaTuaFormula);"";LaTuaFormula)

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Excel 2007 : problemi con una somma":


Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti