Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

valore nella prima cella a sinistra

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

valore nella prima cella a sinistra

Postdi marcoc » 19/09/11 13:51

ho la formula:
=SCARTO(A1;0;CONTA.SE(D1:O1;">=0")+2;1)
che mi riporta il valore dell'ultima colonna compilata dalla D alla O in riga1.
ho bisogno la formula "inversa", ovvero che mi riporti il valore della prima colonna compilata in riga1.

idee?
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Sponsor
 

Re: valore nella prima cella a sinistra

Postdi CANAPONE » 19/09/11 15:04

Ciao,

=INDICE(D1:O1;CONFRONTA(VERO;INDICE(D1:DO1<>"";);0))

dovrebbe bastare.

----------------

Per ottenere il valore nell'ultima cella non vuota, puoi usare anche

=CERCA(2;1/(D1:O1<>"");D1:O1)

La formula ha il vantaggio di non essere volatile (rimando alla rete per il significato)

Facci sapere se può andare.

Ciao
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: valore nella prima cella a sinistra

Postdi marcoc » 19/09/11 15:10

perfetto!

la formula che ho scritto prima
=SCARTO(A1;0;CONTA.SE(D1:O1;">=0")+2;1)
si sballa se ad esempio ci sono valori dalla F alla O.

sai riadattare quella che mi hai appena scritto a questo caso?
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Re: valore nella prima cella a sinistra

Postdi CANAPONE » 19/09/11 15:19

Ciao, spero di aver capito

=CERCA(2;1/((D1:O1>=0)*(D1:O1<>""));D1:O1)

Questa formula restituisce il contenuto dell'ultima cella in D1:O1 che non sia vuoto e che sia superiore a zero.

Il 2 della formula - per curiosità- lo puoi sostituire con qualsiasi numero superiore a 1.

Saluti
Ultima modifica di CANAPONE su 19/09/11 15:25, modificato 1 volte in totale.
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: valore nella prima cella a sinistra

Postdi marcoc » 19/09/11 15:24

hai capito bene, grazie!
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano


Torna a Applicazioni Office Windows


Topic correlati a "valore nella prima cella a sinistra":


Chi c’è in linea

Visitano il forum: Nessuno e 14 ospiti