Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

CERCA VERT. restituisce 0 o #N/D ma il valore c'è

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

CERCA VERT. restituisce 0 o #N/D ma il valore c'è

Postdi marzia.cubito » 07/09/11 12:06

Ciao a tutti... ho provato a leggere tutti i messaggi precedenti ed applicare i preziosi suggerimenti, ma non ho risolto il mio problema.
Ho un file excel con 2 fogli e devo cercare nel 2° i numeri di fattura presenti nel 1°. Se presenti, restituire il valore "pagabile".
Ho provato le due funzioni:
=SE(VAL.NON.DISP(CERCA.VERT('2011'!E3;Luglio!$A$2:$C$11;2;FALSO));0;CERCA.VERT(E3;Luglio!$A$2:$C$11;2;FALSO))
=CERCA.VERT(E4;Luglio!$A$2:$C$11;2;FALSO)
ma benchè presenti entrambi i valori, ottengo sempre 0 e #N/D... dove sbaglio?
Grazie del vs. aiuto...
marzia.cubito
Newbie
 
Post: 2
Iscritto il: 07/09/11 11:31

Sponsor
 

Re: CERCA VERT. restituisce 0 o #N/D ma il valore c'è

Postdi CANAPONE » 07/09/11 12:38

Ciao, il cerca.vert con 0 (zero o FALSO) come quarto argomento accoppia corrispondenze esatte.
Spesso celle che sembrano uguali, contenguono o spazi o caratteri non editabili: qui avremmo bisogno di vedere incollate su un file la colonna di dati non riconosciuta e con cosa viene confrontata.

Lei formule sono formulate (scusa l'alliterazione) bene, mi sembra solo che il secondo argomento del cerca.vert abbia un riferimento un po' limitato. Mi riferisco- se stai lavorando con le formule che hai pubblicato- ad A2:A11: sono 10 righe di fatture.
Forse devi sostituire semplicemente 11 con - tiro ad indovinare- 1000 o 2000.

Ci ho provato.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: CERCA VERT. restituisce 0 o #N/D ma il valore c'è

Postdi Anthony47 » 07/09/11 13:52

Ciao marzia, benvenuta nel forum.
La formula e' come idea corretta ma come realizzazione sbagliata: non
=SE(VAL.NON.DISP(CERCA.VERT('2011'!E3;Luglio!$A$2:$C$11;2;FALSO));0;CERCA.VERT(E3;Luglio!$A$2:$C$11;2;FALSO))
Ma
=SE(VAL.NON.DISP(CERCA.VERT('2011'!E3;Luglio!$A$2:$C$11;2;FALSO));0;CERCA.VERT('2011'!E3;Luglio!$A$2:$C$11;2;FALSO))

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: CERCA VERT. restituisce 0 o #N/D ma il valore c'è

Postdi marzia.cubito » 07/09/11 14:24

Innanzitutto grazie a tutti... ho provato a seguire i suggerimenti, ma non ho risolto:
1) ho corretto la formula come suggerito da Anthony47
2) ho verificato che le celle in confronto siano uguali, ho annullato gli spazi ed ho messo tutto come numero (in realtà il file che devo lavorare è di ben 7000 righe, ma ne ho creato uno fittizio con 10 righe solo per capire l'errore della formula)

Non c'è modo di mardarvi il file così mi dite cos'altro sbaglio?
marzia.cubito
Newbie
 
Post: 2
Iscritto il: 07/09/11 11:31

Re: CERCA VERT. restituisce 0 o #N/D ma il valore c'è

Postdi Anthony47 » 07/09/11 14:30

Con quella formula non dovresti mai avere #N/D. Se pensi di aver guardato bene e sei convinta che quello che cerchi sia presente "tale e quale" nell' elenco in cui cerchi allegaci un file, con una formula che produce il risultato errato.
Trovi la procedura qui: viewtopic.php?f=26&t=80395

Per allegare il link devi prima aver scritto 3 messaggi, ne puoi scrivere uno di comodo per fare numero.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "CERCA VERT. restituisce 0 o #N/D ma il valore c'è":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti