Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[EXCEL]Trova 1° cella non vuota in un intervallo

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[EXCEL]Trova 1° cella non vuota in un intervallo

Postdi marte1503 » 05/09/11 21:54

Ciao a tutti
Che formula si deve usare per trovare la prima cella non vuota in un intervallo di celle (es. da A1:A10)?

Specifico che le celle non sono davvero vuote, ma contengono una formula che in un detrminato caso rende invisibile il contenuto es. =SE(A1="pippo";A1;"") e il tipo di formattazione è impostato su generale

Grazie
marte 1503
marte1503
Utente Senior
 
Post: 174
Iscritto il: 08/01/10 20:43
Località: Como

Sponsor
 

Re: [EXCEL]Trova 1° cella non vuota in un intervallo

Postdi Flash30005 » 05/09/11 22:48

Fai il classico ciclo For... next
però dovrai usare la condizione SE sul valore cella con
Codice: Seleziona tutto
If Val(Range("A" & RR)) <> 0 then 'fai quello che devi fare quando trovi la prima cella non "vuota"


Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: [EXCEL]Trova 1° cella non vuota in un intervallo

Postdi Anthony47 » 05/09/11 23:38

Se invece del vba (vedi post di Flash sopra) ti interessa farlo con formula
Codice: Seleziona tutto
=MIN(SE(A1:A10<>"";RIF.RIGA(A1:A10);""))
da confermare con Contr-Maiusc-Enter

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [EXCEL]Trova 1° cella non vuota in un intervallo

Postdi marte1503 » 06/09/11 19:35

Ciao Flash, ciao Anthony
Grazie 1000 per le vostre risposte.

Per risolvere questa questione nel mio caso è meglio utilizzare una formula, quindi scelgo la soluzione suggerita da Anthony.

Ultima cosa (Anthony), è possibile modificare la tua formula in modo da ottenere direttamente il contenuto della cella al posto del numero di riferimento riga? (mi snellirebbe le operazioni successive).

Grazie in anticipo per il nuovo aiuto

marte1503
marte1503
Utente Senior
 
Post: 174
Iscritto il: 08/01/10 20:43
Località: Como

Re: [EXCEL]Trova 1° cella non vuota in un intervallo

Postdi CANAPONE » 07/09/11 10:48

Ciao a tutti,

INDICE/CONFRONTA dovrebbe esserti d'aiuto:

=INDICE($A$1:$A$10;CONFRONTA(VERO;INDICE($A$1:$A$10<>"";0);0))


Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [EXCEL]Trova 1° cella non vuota in un intervallo

Postdi marte1503 » 07/09/11 21:23

Ciao Canapone,
ho inserito la tua formula, funziona perfettamente!
Ti ringrazio!

Alla prossima.

Marte1503
marte1503
Utente Senior
 
Post: 174
Iscritto il: 08/01/10 20:43
Località: Como


Torna a Applicazioni Office Windows


Topic correlati a "[EXCEL]Trova 1° cella non vuota in un intervallo":


Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti