Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Ricerca numeri all'interno di una tabella

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Ricerca numeri all'interno di una tabella

Postdi mazingaa80 » 05/07/11 20:22

Avendo una tabella con 10 colonne e 14 righe che presenta tutte le celle riempite con numeri che vanno da 1 a 30 vorrei sapere se, nelle prime 7 righe, il numero 1 è uscito 1 volta, e allo stesso tempo se nelle prime 14 righe quel numero 1 è presente 6 volte. In caso di esito positivo vorrei che appaia, accanto all'ultima colonna (colonna K) la scritta: "BENE"
La stessa cosa la vorrei ottenere non solo per il numero 1 ma per tutti i numeri fino al 30.
Grazie
mazingaa80
Newbie
 
Post: 7
Iscritto il: 04/10/10 19:06

Sponsor
 

Re: Ricerca numeri all'interno di una tabella

Postdi Statix » 05/07/11 20:34

Ciao mazingaa80,
potresti applicare questa formula per ogni numero,
supponendo che i tuoi dati siano in A1:J14

Codice: Seleziona tutto
=SE(E(CONTA.SE($A$1:$J$7;1)>=1;CONTA.SE($A$1:$J$14;1)>=6);"Bene";"")
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Ricerca numeri all'interno di una tabella

Postdi Statix » 05/07/11 20:53

se vuoi vedere tutti i 30 numeri ,
metti da K1 a AN1 i numeri da 1 a 30
puoi fare come in foto,applicando questa formula in K3 e copiandola fino a AN3
ovviamente devi modificare in base ai tuoi riferimenti

Codice: Seleziona tutto
=SE(E(CONTA.SE($A1:$J7;K$1)>=1;CONTA.SE($A1:$J14;K$1)>=6);"Bene";"")


Immagine
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Ricerca numeri all'interno di una tabella

Postdi mazingaa80 » 10/07/11 13:03

ciao Statix, grazie per il consiglio! sono vari giorni che sto provando a far funzionare questa funzione ma mi risulta troppo complessa! a questo punto credo che sarebbe più opportuna una macro..
Mi spiego meglio: come ho già detto
vorrei sapere se, nelle prime 7 righe, il numero 1 è uscito 1 volta (e poi il numero 2, poi il numero 3, fino a 30), e allo stesso tempo se nelle prime 14 righe quel numero 1 (e poi il numero 2, poi il numero 3, fino a 30) è presente 6 volte.
Quindi scrivere tutte queste condizioni in una funzione, così come me l'hai gentilmente suggerita, risulta essere veramente troppo macchinosa (sarebbero circa 60 condizioni all'interno della stessa funzione).

Spero possiate aiutarmi!! grazie a tutti
mazingaa80
Newbie
 
Post: 7
Iscritto il: 04/10/10 19:06

Re: Ricerca numeri all'interno di una tabella

Postdi Anthony47 » 11/07/11 23:09

La soluzione di Statix richiede:
-che ti crei la lista dei numeri da 1 a 30 in K1:AN1
-che scrivi una formula in K2
-che copi K3 nelle celle K3:AN3
Non mi sembra cosi' complesso...

Dove ti sei arenato?
Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Ricerca numeri all'interno di una tabella":


Chi c’è in linea

Visitano il forum: alfrimpa, giorgio1979 e 10 ospiti