Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Trova le Decine di apparteneza dei numeri

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Trova le Decine di apparteneza dei numeri

Postdi luigi99 » 09/06/11 17:41

Sono alla ricerca di una formula che mi dica a quale decina appartiene il numero in casella:
10= 1, 18= 1, 43= 4 ecc. ecc.
I numeri da 1 a 9 e il n° 90 dovrebbero dare come esito 0 (zero).
In rete ho trovato queste due formule:
=SE((A2*1=9);A2*1-9;A2*1) (che non funziona per niente e non ne ho capito il senso!!!)
questa invece funziona, ma con il 90 mi da 9.
= SE(LUNGHEZZA(D7)=2;SINISTRA(D7);"0")
ho provato :oops: ad aggiungere l'opzione in vari modi, ma non riesco a risolvere :neutral: :neutral:
Grazie.
ex Autodidatta, ma ancora in cerca di grane con il computer
luigi99
Utente Senior
 
Post: 563
Iscritto il: 21/11/01 01:00
Località: Vigliano Biellese

Sponsor
 

Re: Trova le Decine di apparteneza dei numeri

Postdi Avatar3 » 09/06/11 18:01

Formula per valore in A1 (adatta alle coordinate della tua cella)
Codice: Seleziona tutto
=SE(A1=90;0;RESTO(INT(A1/10);90))
Per il funzionamento delle macro si deve impostare la protezione a Bassa o Media.
Menu Strumenti -> Macro -> Protezione...
Avatar utente
Avatar3
Utente Senior
 
Post: 569
Iscritto il: 04/04/11 09:04

Re: Trova le Decine di apparteneza dei numeri

Postdi Anthony47 » 09/06/11 23:49

Oppure anche
Codice: Seleziona tutto
=INT(RESTO(A1;90)/10)


Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Trova le Decine di apparteneza dei numeri

Postdi ricky53 » 09/06/11 23:58

Ciao,
se i numeri sono da 1 a 90 allora puoi utilizzare la formula
Codice: Seleziona tutto
=INT(A1/10)
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Trova le Decine di apparteneza dei numeri

Postdi Avatar3 » 10/06/11 02:47

La più sintetica e funzionale è la formula di Antony :)
Quella mia soddisfa l'esigenza ma è "prolissa" :x
Quella di Richy non soddisfa l'esigenza (in caso di 90 dà come risultato 9 invece che lo 0 richiesto dall'utente) :roll:
Per il funzionamento delle macro si deve impostare la protezione a Bassa o Media.
Menu Strumenti -> Macro -> Protezione...
Avatar utente
Avatar3
Utente Senior
 
Post: 569
Iscritto il: 04/04/11 09:04

Re: Trova le Decine di apparteneza dei numeri

Postdi Francesco53 » 10/06/11 08:24

Anche questa va bene:
Codice: Seleziona tutto
=SE(LUNGHEZZA(A1)<2;0;SINISTRA(A1))

Francesco
S.O. Vista e Office 2007
Francesco53
Utente Senior
 
Post: 647
Iscritto il: 20/02/10 18:45

Re: Trova le Decine di apparteneza dei numeri

Postdi ricky53 » 10/06/11 10:40

Ciao,
VERO Avatar, non ho riportato che la formula andava sempre sotto la condizione "SE" sul valore "90", quindi, avrei dovuto scrivere:
Codice: Seleziona tutto
=SE(A1=90; 0; INT(A1/10))


Comunque il grande Anthony non si smentisce mai !!!
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Trova le Decine di apparteneza dei numeri

Postdi luigi99 » 10/06/11 15:43

ambarabbà ciccì cocò quale formula sceglierò ????? Immagine
grazie a tutti.
Luigi
ex Autodidatta, ma ancora in cerca di grane con il computer
luigi99
Utente Senior
 
Post: 563
Iscritto il: 21/11/01 01:00
Località: Vigliano Biellese


Torna a Applicazioni Office Windows


Topic correlati a "Trova le Decine di apparteneza dei numeri":


Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti