Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

data più grande

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

data più grande

Postdi Statix » 27/05/11 10:26

Ciao, rieccomi sono di nuovo quì con un altro problemino,
dovrei cercare la data più grande,nel senso la più recente.
esempio ho 6 celle A1:A6
12/02/2010
13/05/2001
14/04/2011
Vuota
01/01/2011
26/05/2011

quindi tra queste sei celle la più recente è
26/05/2011,
in rete ho trovato questa formula,che ho adattato ai miei range ma incredibilmente non funziona,
dove sbaglio?

Codice: Seleziona tutto
=MAX(SE(((SE(VAL.VUOTO(ANNO(A1:A6)); 1900))>1900);ANNO(A1:A6)))

poi confermata come matrice,

http://blog.teammatelabs.com/2011/02/27 ... -con-exce/
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Sponsor
 

Re: data più grande

Postdi Statix » 27/05/11 10:50

Ho fatto ulteriori prove formattando le celle,
la formula mi ricava solo l'anno,
a me serve la data intera,eppure nel link parlava della data intera se non sbaglio,mah.
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: data più grande

Postdi Statix » 27/05/11 11:09

ho risolto con una colonna appoggio mettendo questa formula in B1 cella formattata Generale
Codice: Seleziona tutto
=SE(A1="";"";A1)

che poi ho copiato fino a B6 e in C1 =max(B1:B6) cella formattata data
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: data più grande

Postdi Avatar3 » 27/05/11 13:07

puoi usare solo questa formula (e formattare la cella come data)
Codice: Seleziona tutto
=GRANDE(A1:A6;1)
Per il funzionamento delle macro si deve impostare la protezione a Bassa o Media.
Menu Strumenti -> Macro -> Protezione...
Avatar utente
Avatar3
Utente Senior
 
Post: 569
Iscritto il: 04/04/11 09:04


Torna a Applicazioni Office Windows


Topic correlati a "data più grande":


Chi c’è in linea

Visitano il forum: Anthony47 e 7 ospiti