Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Date

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Date

Postdi Cedamido » 23/05/11 13:36

In un elenco di date che calcolaro i giorni vorrei che quando le date superano i 10 giorni giorni indicasse nella colonna a fianco 10, per le date inferiori o pari a 10 giorni lasciare i giorni effettivi.
Grazie
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Sponsor
 

Re: Date

Postdi Avatar3 » 23/05/11 20:31

Potresti spiegare meglio il tuo problema?
L'elenco date è in colonna e le date sono sequenziali?
oppure la differenza data è rispetto alla data posta alla riga precedente?
Per il funzionamento delle macro si deve impostare la protezione a Bassa o Media.
Menu Strumenti -> Macro -> Protezione...
Avatar utente
Avatar3
Utente Senior
 
Post: 569
Iscritto il: 04/04/11 09:04

Re: Date

Postdi Cedamido » 23/05/11 20:44

In effetti non ho spiegato bene.
Dal 23/05/2011 al 26/05/2011 dovrebbe riportare giorni 4, tutte le date che non superano i 10 giorni dovrebbero indicare i giorni effettivi incluso la data iniziale.
Dal 20/05/2011 al 29/05/2011 dovrebbe riportare giorni 10.
Dal 20/05/2011 al 30/05/2011 dovrebbe riportare giorni 10 perchè sono 11 quindi supera i 10 giorni, tutte le date che superano i 10 giorni dovrebbero riportare giorni 10.
Se in elenco non vi sono date non deve riportare giorni 1 ma zero oppure nulla.
Le date sono colonna A cella A3 data iniziale colonna B da B3 data finale sino alla cella A33 e B33.
Grazie per l'interessamento.
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Re: Date

Postdi Avatar3 » 23/05/11 20:55

In C3 inserisci questa formula
Codice: Seleziona tutto
=SE(A3="";"";SE((B3-A3+1)>10;10;B3-A3+1))

(formatta la cella come numero)
Trascina verso il basso fino dove occorre
Per il funzionamento delle macro si deve impostare la protezione a Bassa o Media.
Menu Strumenti -> Macro -> Protezione...
Avatar utente
Avatar3
Utente Senior
 
Post: 569
Iscritto il: 04/04/11 09:04

Re: Date

Postdi Cedamido » 23/05/11 21:33

Funziona bene, ma è sorto altro problemino,nel senso che, se non vi sono date la colonna C non portando zero a seguire nelle altre colonne non fa i conti, appare la scritta VALORE, si potrebbe risolvere?
Grazie
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Re: Date

Postdi Avatar3 » 23/05/11 21:53

Beh tu mi hai detto che in caso di nessuna data inserire 0 o nulla e io ho optato per nulla
se vuoi lo zero cambia gli apici "" con 0
Codice: Seleziona tutto
=SE(A3="";0;SE((B3-A3+1)>10;10;B3-A3+1))
Per il funzionamento delle macro si deve impostare la protezione a Bassa o Media.
Menu Strumenti -> Macro -> Protezione...
Avatar utente
Avatar3
Utente Senior
 
Post: 569
Iscritto il: 04/04/11 09:04

Re: Date

Postdi Cedamido » 24/05/11 16:22

Ok grazie.
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26


Torna a Applicazioni Office Windows


Topic correlati a "Date":


Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti