Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel] riportare risultati in base al confronto delle celle

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel] riportare risultati in base al confronto delle celle

Postdi contiend » 02/05/11 18:23

Ciao a tutti,
io dovrei riuscire a creare una tabella ma non so nemmeno da dove partire.
Il problema è spiegato nell'allegato

https://rapidshare.com/files/460277010/totreti.xlsx

(riporto il testo all'interno)
( Io ho questa tabella a SINISTRA vorrei creare una tabella sulla destra che mi permetta di scegliere con un menu a tendina tra le squadre disponibili e poi mi riporti il totale delle reti segnate nelle sfide da una e dall'altra squadra.)



Grazie dell'attenzione.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45

Sponsor
 

Re: [excel] riportare risultati in base al confronto delle c

Postdi ricky53 » 02/05/11 22:29

Ciao,
puoi inserire anche la struttura della tabella perchè il link sarà attivo per poco tempo e poi si perderà la possibilità di capire la tua esigenza e altri utenti non capiranno quale era stata la tua richiesta.

Puoi fare un esempio con i nomi delle squadre ed i valori che ti aspetti vengano calcolati dalle formule.
Andata e Ritorno vanno calcolati separati ?
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [excel] riportare risultati in base al confronto delle c

Postdi ricky53 » 02/05/11 22:50

Ciao,
i dati, a mio avviso, non sono organizzati bene: come distingui un campionato dall'altro e l'andata dal ritorno.

La struttura dati deve essere omogenea e ogni diversa tipologia di i dati deve stare su colonne diverse.
I datinon devono essere inseriti nella modalità corrispondente alla visualizzazione voluta ma in base a regole precise per poterli elaborare ...

I dati dovrebbero essere organizzati almeno così
Numero campionato, tipo incontro (andata o ritorno), data incontro, Sq-A, Sq-B, gol Fatti, gol Subiti

c'è la possibilità di riorganizzarli.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [excel] riportare risultati in base al confronto delle c

Postdi Anthony47 » 02/05/11 23:03

Sposo l' invito di Ricky a descrivere nel messaggio e non nell' allegato il problema, dovendosi considerare l' allegato un "complemento" e non una "sostituzione" della descrizione del problema.

Nel caso specifico, si tratta di un torneo con Squadra1 in col B, Squadra2 in col C e i punti fatti dalle due squadre in col D ed E.

Per la domanda posta:
In G6 e H6 inserisci una convalida da elenco, e indica come "Origine" le celle che contengono l' elenco delle squadre
Poi in I6 usi la formula
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(B1:B1000=G6);--(C1:C1000=H6);D1:D1000)+MATR.SOMMA.PRODOTTO(--(B1:B1000=H6);--(C1:C1000=G6);E1:E1000)

E in J6
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(B1:B1000=G6);--(C1:C1000=H6);E1:E1000)+MATR.SOMMA.PRODOTTO(--(B1:B1000=H6);--(C1:C1000=G6);D1:D1000)

In questo modo in G6 e H6 potrai selezionare due squadre, e calcolerai i rispettivi punti negli incontri diretti in I6 e J6.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [excel] riportare risultati in base al confronto delle c

Postdi ricky53 » 03/05/11 00:05

Ciao Anthony,
ma non devono essere separati i vari tornei e le andate dai ritorni ?

Era una cosa che volevo capire e che avevo chiesto.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [excel] riportare risultati in base al confronto delle c

Postdi Anthony47 » 03/05/11 00:50

Da quello che ho capito si tratta di un unico torneo, suddiviso in Andata e Ritorno; le formule che ho dato sommano sia i punti dell' Andata che del Ritorno (la mia interpretazione di "e poi mi riporti il totale delle reti segnate nelle sfide da una e dall'altra squadra"). I due punteggi (Andata e Ritorno) sono nelle due componenti della formula, sommati col +
Se contiend vuole il disaggregato puo' scomporre le formule; se voleva una cosa diversa allora postera' ancora.

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [excel] riportare risultati in base al confronto delle c

Postdi contiend » 09/05/11 00:31

Eccomi.
Intanto mi scuso per aver intestato male il messaggio sul forum.
Sono stato offline per qualche giorno.

Ringrazio tantissimo tutti per la disponibilità.
Ringrazio ancora di più Anthony47 : le formule che mi hai dato funzionano perfettamente e fanno proprio quello che volevo.

Grazie a tutti.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45


Torna a Applicazioni Office Windows


Topic correlati a "[excel] riportare risultati in base al confronto delle celle":


Chi c’è in linea

Visitano il forum: Marius44 e 5 ospiti