Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

sottrai 1 se due celle sono maggiori di 0

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

sottrai 1 se due celle sono maggiori di 0

Postdi trittico69 » 27/04/11 23:29

Potete farmi una formula che dice
Se A1 è maggiore di 0 e A2 è maggiore di 0 allora scrivi in A3 il numero 1
In pratica dovrei sottrarre 1 alla cella assegnata questa formula =SOMMA(K14:K58)-AW13-A3 in quest’ultima A3 ci deve essere 1 se c’è la condizione detta in A2 e A3..
Oppure allungare la stessa formula in questo modo
=SOMMA(K14:K58)-AW13e sottrai 1 se A1 è maggiore di 0 e A2 è maggiore di 0
Grazie!
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Sponsor
 

Re: sottrai 1 se due celle sono maggiori di 0

Postdi ricky53 » 27/04/11 23:45

Ciao,
prova in questo modo
Codice: Seleziona tutto
=SOMMA(K14:K58)-AW13 + SE(E(A1>0; A2>0); -1; 0)
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: sottrai 1 se due celle sono maggiori di 0

Postdi trittico69 » 27/04/11 23:52

grazie funziona
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Re: sottrai 1 se due celle sono maggiori di 0

Postdi ricky53 » 27/04/11 23:54

Ciao,
bene.

Ricordati degli altri forum.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: sottrai 1 se due celle sono maggiori di 0

Postdi trittico69 » 28/04/11 00:01

aspetta forse c'è qualcosa che non va
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Re: sottrai 1 se due celle sono maggiori di 0

Postdi trittico69 » 28/04/11 00:05

SE(E(K47>0; L47>0); -1; 0)
se k47>0 oppure L47>0); -1; 0)
se non sbaglio il significato è questo...ma a me serve
se k47>0 e in contemporanea L47>0); -1; 0)
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Re: sottrai 1 se due celle sono maggiori di 0

Postdi ricky53 » 28/04/11 10:28

Ciao,
NO !!!

"E" sta per "Entrambe le condizioni sono Verificate"
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: sottrai 1 se due celle sono maggiori di 0

Postdi trittico69 » 28/04/11 10:49

se in A2 c'è 0,25 e in A1 la cella è vuota mi sottrae 1
se invece entrambe A1 e A2 sono vuote non mi sottrae 1 e va bene
o dipende da altro?
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Re: sottrai 1 se due celle sono maggiori di 0

Postdi ricky53 » 28/04/11 11:22

Ciao,
scrivere in più forum crea problemi.

Leggi quanto scritto nell'altro forum cui ti ho risposto.

Comunque dipende dal contenuto delle celle ... controlla se ci sono spazi o ...

Scusa ma vorrei risponderti in un solo forum.
Scegli tu quale protare avanti e, alla fine, scriverai (in tutti i forum) come è stato risolto il tuo quesito.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: sottrai 1 se due celle sono maggiori di 0

Postdi trittico69 » 28/04/11 15:03

una cella contiene
Codice: Seleziona tutto
=SE(O(A20=$AM$1;A20=$AM$2;A20=$AM$3;A20=$AM$4;A20=$AM$5;A20=$AM$6;A20=$AM$7;A20=$AM$8;A20=$AM$9;A20=$AM$10;A20=$AR$1;A20=$AR$2);1;"")

ed è assegnata alla domenica di un calendario questa formula serve che se di domenica capita un festivo deve segnare 1
l'altra cella contiene
=S20
che puo essere un numero che oscilla da 0 a salire
parlo delle celle A1 e A2
srivo in tutti i forum perchè qualcuno magari mi risponde prima
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Re: sottrai 1 se due celle sono maggiori di 0

Postdi Flash30005 » 28/04/11 17:14

trittico ha scritto:srivo in tutti i forum perchè qualcuno magari mi risponde prima


Leggendo l'orario delle domande fatte e quello delle risposte ricevute in questo Forum sono passati solo "pochi" minuti (tranne una inviata di notte e hai ricevuto la risposta la mattina alle ore 10)

Non sei soddisfatto della tempestività di questo Forum? :aaah

Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: sottrai 1 se due celle sono maggiori di 0

Postdi trittico69 » 28/04/11 18:04

sono contento sia della professionalita che del tempo di risposta di questo forum....e che il mio programmino che sto facendo e quasi finito è da molto tempo che lo iniziato
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41


Torna a Applicazioni Office Windows


Topic correlati a "sottrai 1 se due celle sono maggiori di 0":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti