Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Contare celle vuote in un intervallo variabile

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Contare celle vuote in un intervallo variabile

Postdi blunotte13 » 14/03/11 20:10

Ciao a tutti, in colonna AC, da AC2 a fine elenco, uso la formula =SE(AB1<>"";Ab1;""), l'elenco lo aggiorno circa 15/20 volte al giorno e naturalmente trascino la formula per le celle aggiunte.
Come faccio a sapere quante righe vuote ci sono dall'ultima volta che una cella in AC è stata valorizzata?
Ho provato ad usare queste formule :
in AD2 =SE(AB1<>"";Ab1;"")
in AD3 =SE(AB<>"";CONTA.VUOTE(AD$2);"")
in AD4 =SE(AB4<>"";CONTA.VUOTE(AD$2:AD3)-SOMMA(AD$2:AD3);"")
che funziona, solo che il conto delle celle vuote lo visualizza accanto alla cella con valore di colonna AC, io vorrei, per esempio: ultima cella con valore AD100, ultima cella in elenco AD 115, tutte le celle sono vuote, in B1 mi compare 15, aggiungo i dati all'elenco, la cella AD116 ha un valore, la cella B1 si azzera e ricomincia il conteggio fino a quando non compare un'altre cella con valore in, una cella a caso, AD 216, in B1si azzera il risultato 100 e si ricomincia da capo.

Grazie a tutti in anticipo.
Alla prossima, ciao ciao !!


Excel 2007
blunotte13
Utente Senior
 
Post: 116
Iscritto il: 13/01/10 19:35

Sponsor
 

Re: Contare celle vuote in un intervallo variabile

Postdi Anthony47 » 15/03/11 01:19

Personalmente non riesco a interpretare la richiesta "Come faccio a sapere quante righe vuote ci sono dall'ultima volta che una cella in AC è stata valorizzata?" per un paio di motivi:
-un po' parli di spazio (le righe vuote) un po' parli di tempo (l'ultima volta che una cella in AC è stata valorizzata)
-parli di AD100 e AD115; ma la colonna AD non e' usata solo nelle prime 4 righe?

Magari rileggendo domattina mi si accende una lucina...

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Contare celle vuote in un intervallo variabile

Postdi ricky53 » 15/03/11 01:30

Ciao,
è possible avere una descrizione schematica delle tue necessità e non discorsiva.
Grazie.

Magari la lucina si accende anche ad altri !!!
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Contare celle vuote in un intervallo variabile

Postdi blunotte13 » 15/03/11 01:56

Vediamo se riesco a schematizzare il tutto,
le colonne da A ad AC vengono aggiornate tutti i giorni, quindi le righe aumentano sempre, nella cella AC1, inserisco il dato che mi serve, con le formule che ho scritto prima,

in AD2 =SE(AB1<>"";Ab1;"")
in AD3 =SE(AB<>"";CONTA.VUOTE(AD$2);"")
in AD4 =SE(AB4<>"";CONTA.VUOTE(AD$2:AD3)-SOMMA(AD$2:AD3);"")

la formula in AD4 la trascino fino a fine elenco e se il valore che cerco, ad esempio 50%, è presente, la formula calcola da quante righe non compariva.
Vorrei sapere se è possibile, con una macro, far comparire in cella B1 il numero totale di righe che ci sono tra i due dati che cerco, quando il numero che cerco ricompare in elenco, la cella B1 si azzera e ricomincia a contare le righe vuote fino alla prossima volta che il numero ricompare.
Alla prossima, ciao ciao !!


Excel 2007
blunotte13
Utente Senior
 
Post: 116
Iscritto il: 13/01/10 19:35

Re: Contare celle vuote in un intervallo variabile

Postdi Anthony47 » 15/03/11 14:30

Perdona, ancora molto… blunotte.
il numero totale di righe che ci sono tra i due dati che cerco, quando il numero che cerco ricompare in elenco, la cella B1 si azzera e ricomincia a contare le righe vuote fino alla prossima volta che il numero ricompare

Come si fa a sapere quali sono "i due dati" che cerchi?
Inoltre sotto ogni riga di dati tutte le celle successive sono vuote, come si fa a "contare le righe vuote fino alla prossima volta che il numero ricompare"? Nel senso che posso contare le righe vuote solo dopo che e' stato inserito un dato diverso da "vuoto".
Infine potrebbe essere utile avere uno screenshot con un esempio di dati di partenza (dovrebbe bastare la col AB) e i dati che vorresti calcolare; per le istruzioni vedi qui: viewtopic.php?f=26&t=80395#p466013

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Contare celle vuote in un intervallo variabile

Postdi blunotte13 » 15/03/11 15:06

Chiedo perdono io per farvi perdere più tempo del necessario, qui l'immagine
http://img718.imageshack.us/i/immaginedl.jpg/
Alla prossima, ciao ciao !!


Excel 2007
blunotte13
Utente Senior
 
Post: 116
Iscritto il: 13/01/10 19:35

Re: Contare celle vuote in un intervallo variabile

Postdi Anthony47 » 15/03/11 15:31

Osservo che col Z e' 1 quando contiene "il dato che cerchi", e' 0 quando il dato e' assente; quindi dovresti poter usare questa formula in B1:
Codice: Seleziona tutto
=MAX(SE(Z1:Z1000<>"";RIF.RIGA(Z1:Z1000)))-MAX(SE(Z1:Z1000=1;RIF.RIGA(Z1:Z1000)))
da confermare con Contr-Maiusc-Enter
Se pensi che il tuo elenco possa essere piu' lungo di 1000 righe modifica Z1000 in Zxxxx grosso a piacere; ma piu' e' grande piu' KB di ram ti mangera'.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Contare celle vuote in un intervallo variabile

Postdi blunotte13 » 15/03/11 16:55

Così mi da il riferimento della riga in cui compare l'ultima volta il valore che cerco e va già bene. Ho applicato la formula al foglio di lavoro e riporta che il dato che cerco si trova nella riga 240 ed è giusto, adesso come faccio a dire alla formula di fare la sottrazione tra la riga 240 e l'ultima riga dell'elenco ( adesso sono alla riga 256 ), tenendo presente che l'elenco già tra 10 minuti avrà una riga in più ed è sempre in aumento ?

Scusate se stresso e grazie della disponibilità.
Alla prossima, ciao ciao !!


Excel 2007
blunotte13
Utente Senior
 
Post: 116
Iscritto il: 13/01/10 19:35

Re: Contare celle vuote in un intervallo variabile

Postdi Anthony47 » 15/03/11 19:31

Quella formula ti dovrebbe restituire quanti 0 sono nella colonna Z dopo l' ultimo 1, che mi sembra sia la tua domanda; non mi torna che ti restituisca invece la riga dell' ultimo 1. Collaudata con i dati che hai pubblicato.
Hai modificato la formula per adattarla?
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Contare celle vuote in un intervallo variabile

Postdi blunotte13 » 15/03/11 19:49

Veramente si, ho cambiato z1:z1000 con ac1:10000 che è il range vero del mio foglio e mi restituiva il numero di riga dell'ultima volta che compariva il numero che cerco.

Ho riprovarto adesso e funziona, boh non so cosa dire, comunque funziona.

Grazie dell'aiuto e della pazienza.
Alla prossima, ciao ciao !!


Excel 2007
blunotte13
Utente Senior
 
Post: 116
Iscritto il: 13/01/10 19:35


Torna a Applicazioni Office Windows


Topic correlati a "Contare celle vuote in un intervallo variabile":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti