Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Problemi formula CERCA.VERT

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Problemi formula CERCA.VERT

Postdi mariom » 08/02/11 21:30

Salve a tutti
Ho un problema nella formula excel " =CERCA.VERT($A56;Costo!$B$3:$D$68; 2; FALSO)".
Quando vado a trascrivere i dati , che si trovano nel foglio "Costo", in alcune celle mi compare il valore esatto, in altre mi da l'errore "#N/D".
Qualcuno può darmi una indicazione per come risolvere il problema ?
Avatar utente
mariom
Utente Senior
 
Post: 135
Iscritto il: 31/12/09 17:30

Sponsor
 

Re: Problemi formula CERCA.VERT

Postdi jac0 » 09/02/11 01:35

La funzione è: CERCA.VERT(valore;matrice;indice;bit)
'Valore' è il valore da cercare nella 1a colonna di 'matrice'. 'Valore' può essere un valore, un riferimento o una stringa.
'matrice' è la tabella dei dati. Usare un riferimento a un intervallo o un nome di intervallo.
Se 'bit' è VERO, i valori nella 1a colonna di 'matrice', affinché CERCA.VERT dia il valore corretto, devono essere in ordine crescente: ...; -2; -1; 0; 1; 2; ...; A-Z; FALSO; VERO. Se 'bit' è FALSO, l'ordine detto non è necessario.
I valori nella 1a colonna di 'matrice' possono essere testo, numeri o valori logici. La funzione non rileva le maiuscole.
'Indice' è il numero di colonna in 'matrice' che deve dare il valore. 'Indice' = a 1 dà il valore nella 1a colonna di 'matrice', 'indice' = a 2 dà il valore nella 2a colonna di 'matrice' e così via. Se 'indice' è < di 1, CERCA.VERT dà #VALORE!. Se 'indice' è > del numero di colonne di 'matrice', CERCA.VERT dà #RIF!.
'bit' è un valore logico che specifica il tipo di ricerca che CERCA.VERT deve eseguire. Se è VERO o è omesso, verrà restituita una corrispondenza approssimativa, ovvero il valore più grande che sia < di 'valore'. Se è FALSO, CERCA.VERT cerca una corrispondenza esatta. Se non viene trovata, viene dato #N/D. Se CERCA.VERT non trova 'valore' e 'bit' è VERO, usa il valore più grande <= a 'valore'. Se 'valore' è < del valore più piccolo della 1a colonna di 'matrice', CERCA.VERT dà #N/D. Se CERCA.VERT non trova 'valore' e 'bit' è FALSO, CERCA.VERT dà #N/D.
Tre bugie: tasso zero, gratta e vinci, tutto a metà prezzo
jac0
Newbie
 
Post: 8
Iscritto il: 19/12/10 10:43

Re: Problemi formula CERCA.VERT

Postdi Anthony47 » 09/02/11 11:56

Come scritto "tra le righe" da jac0, evidentemente alcuni dati non sono presenti nell' intervallo Costo!$B$3:$D$68; sono quelli per cui la formula ti restituisce #N/D.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Problemi formula CERCA.VERT

Postdi ricky53 » 09/02/11 12:09

Ciao,
per eliminare il fastidioso "#N/D" puoi utilizzare la seguente formula:
Codice: Seleziona tutto
=SE(VAL.ERRORE(CERCA.VERT($A56;costo!$B$3:$D$68;2;FALSO)); "Dato non presente"; CERCA.VERT($A56;costo!$B$3:$D$68;2;FALSO))
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Problemi formula CERCA.VERT

Postdi mariom » 09/02/11 21:31

Salve a tutti

I dati sul foglio costo ci sono tutti.
La stessa formula nella pagina costo con la stessa voce funziona =CERCA.VERT(B90; $B$3:$D$86; 2; FALSO).
E quello che a me suona strano è perchè con alcune voci la formula funziona e con altre no ?? :( .
Avatar utente
mariom
Utente Senior
 
Post: 135
Iscritto il: 31/12/09 17:30

Re: Problemi formula CERCA.VERT

Postdi ricky53 » 09/02/11 23:53

Può dipendere dalla "voce": forse contengono spazi o caratteri non editabili, presumibilmente alla fine della "voce".
Controlla con "F2" e guarda dove si posizione il cursore oppure con =Lunghezza(tua cella contenente la "voce" per la quale il CERCA.VERT non funziona) e poi riscontra il valore con il numero di caratteri della "voce"
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Problemi formula CERCA.VERT

Postdi mariom » 11/02/11 13:42

Ciao ricky53
Ho eseguito quanto mi hai detto nella tua risposta ma niente non funziona ancora...... :cry: comincio a scoraggiarmi.
Avatar utente
mariom
Utente Senior
 
Post: 135
Iscritto il: 31/12/09 17:30

Re: Problemi formula CERCA.VERT

Postdi ricky53 » 11/02/11 14:20

A questo punto conviene vedere il file.

Invia un tuo file di esempio ma senza dati riservati.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Problemi formula CERCA.VERT

Postdi mariom » 11/02/11 22:23

Salve a tutti

Ho allegato il file incriminato, spero di aver usato il modo giusto per l'inserimento.
http://rapidshare.com/files/447432699/PROVA.xls.
Avatar utente
mariom
Utente Senior
 
Post: 135
Iscritto il: 31/12/09 17:30

Re: Problemi formula CERCA.VERT

Postdi Anthony47 » 11/02/11 23:42

La formula che usi non e' =CERCA.VERT($A56;Costo!$B$3:$D$68; 2; FALSO) ma =CERCA.VERT($A56;Costo!$B$3:$D$11; 2; FALSO)
Di conseguenza tutte le descrizioni che su foglio Costo sono dopo la riga 11 e' come se non esistessero.

Insomma devi usare …la formula suggerita da te stesso.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Problemi formula CERCA.VERT

Postdi ricky53 » 12/02/11 00:41

Ciao,
ma ... ma ...
ma come pensi di trovare un dato se lo cerchi fino alla riga "11"

=CERCA.VERT($A12;Costo!$B$3:$D$11; 2; FALSO)


quando il dato è nella riga "21"
Cambia l'intervallo di ricerca in

CERCA.VERT($A12;Costo!$B$3:$D$100; 2; FALSO)
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Problemi formula CERCA.VERT

Postdi mariom » 12/02/11 15:01

Ok grazie ragazzi adesso funziona, come sempre la fretta non paga mai. :oops:
Avatar utente
mariom
Utente Senior
 
Post: 135
Iscritto il: 31/12/09 17:30


Torna a Applicazioni Office Windows


Topic correlati a "Problemi formula CERCA.VERT":


Chi c’è in linea

Visitano il forum: Nessuno e 15 ospiti