Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

filtro numeri a lotto

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

filtro numeri a lotto

Postdi vittotto » 08/02/11 12:07

Salve non sn molto esperto di forum ma espongo il mio problema mi serve una funzione o macro, praticamente in un foglio inserisco l'ultima estrazione di tutte le ruote tipo primo estratto in b2, 2° estratto c2 ecc.... vorrei una funzione che mi visualizza i numeri non usciti da 1 a 90( ovvio 1 a 90 meno quelli usciti ) ,non so' se sn stato chiaro ,una specie di filtro , sara' una funzione facile ma sto alle prime armi con excel, ringrazio molto per l'aiuto .
allego file esempio
http://rapidshare.com/files/446729699/f ... umeri.xlsx
vittotto
Utente Junior
 
Post: 24
Iscritto il: 22/01/11 20:54

Sponsor
 

Re: filtro numeri a lotto

Postdi Anthony47 » 08/02/11 15:30

Premetto che il link pubblicato e' monco quindi non ho guardato il tuo file.
Ad esempio:
-i tuoi dati sono in B2:F2
-in H2 metti la formula
Codice: Seleziona tutto
=SE(CONTA.SE($B2:$F2;RIF.COLONNA(A1))=0;RIF.COLONNA(A1);"")

-copi H2 fino a CS2
In questo modo i numeri che non sono in elenco degli estratti non saranno presenti nell' elenco
creato con le formule.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: filtro numeri a lotto

Postdi vittotto » 09/02/11 00:17

Grz antony era quasi quello che volevo solo i miei dati sono in b2:f11 sono tutte le dieci ruote del lotto ,come potrei adattare la tua formula ? e potrei visuallizarli in una sola colonna invece di visualizzarli fino a cs2 ?
vittotto
Utente Junior
 
Post: 24
Iscritto il: 22/01/11 20:54

Re: filtro numeri a lotto

Postdi Anthony47 » 09/02/11 11:54

Secondo me ti infili in un vicolo cieco…
Comunque:
-da excel, Alt-F11; ti si apre l' editor delle macro
-Menu /Inserisci /Modulo
-copia questo codice nel frame vuoto di dx
Codice: Seleziona tutto
Function dumb(area)
Dim I As Byte
For I = 1 To 90
If Application.WorksheetFunction.CountIf(area, I) = 0 Then dumb = dumb & I & " "
Next I
End Function
Torna su excel e in H2 inserisci la formula
Codice: Seleziona tutto
=dumb(B2:F2)
poi copia H2 fino ad H11

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: filtro numeri a lotto

Postdi vittotto » 09/02/11 21:51

Grazie Antony cosi' va molto meglio e' come volevo io
ciao
vittotto
Utente Junior
 
Post: 24
Iscritto il: 22/01/11 20:54


Torna a Applicazioni Office Windows


Topic correlati a "filtro numeri a lotto":


Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti