Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Somma intervallo righe

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Somma intervallo righe

Postdi Statix » 30/01/11 12:35

Ciao a tutti,
ho problemi a fare la somma di una colonna in base a 2 valori di riga,
esempio
M1=3
O1 = 35
in P1 devo sommare la colonna G da 3 a 35,
ho provato con
Codice: Seleziona tutto
=SOMMA(SCARTO(G$7;0;0;O3;1))
somma (scarto mi funziona
poi quando cerco di copiare verso il basso non mi calcola giusto

Immagine
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Sponsor
 

Re: Somma intervallo righe

Postdi Statix » 30/01/11 12:39

Ho fatto un pò di confusione nel postare l'esempio,
ho allegato un immagine
dovrei fare la somma della colonna G in P3
da riga (valore in M3 a riga valore in O3)
e cosi con le successive
Somma della colonna G in P4

da riga (valore in M4 a riga valore in O4)
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Somma intervallo righe

Postdi Statix » 30/01/11 12:45

Dimenticavo una cosa importante la colonna G
parte da G7 ,quindi il conteggio delle righe
dovrebbe partire da riga 7
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Somma intervallo righe

Postdi Anthony47 » 30/01/11 12:48

Ad esempio
Codice: Seleziona tutto
=Somma(Indiretto("G"&P3&":G"&O3))
(oppure "G"&P3+7&":G"&O3, non ho capito bene il layout dati.
Questa formula va digitata in ognuna delle celle in cui vuoi un tale risultato; per fare una formula copiabile vorrei un file esempio dei tuoi dati.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Somma intervallo righe

Postdi Anthony47 » 30/01/11 12:50

Oppure
Codice: Seleziona tutto
=Scarto(G$7;P3;0;O3-P3;1)


Ri-ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Somma intervallo righe

Postdi Statix » 30/01/11 12:55

Ciao Anthony,l'avevo gia provata non va,
le righe di Inizio sono in M3 e quelle di Fine in O3 risultato in P3

la colonna da sommare parte da G7 da riga M3 a O3 risultato in P3

la colonna da sommare parte da G7 da riga M4 a O4 risultato in P4

la colonna da sommare parte da G7 da riga M5 a O5 risultato in P5
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Somma intervallo righe

Postdi Statix » 30/01/11 13:28

Ciao Anthony47,
tutto ok ho modificato la formula aggiungendo 6 righe

Codice: Seleziona tutto
=SOMMA(INDIRETTO("G"&M3+6&":G"&O3+6))


grazie
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Somma intervallo righe

Postdi Anthony47 » 30/01/11 13:32

Allora andra' bene anche
Codice: Seleziona tutto
=Scarto(G$7;P3-1;0;O3-P3;1)
(o probabilmente ";O3-P3+1;") che dovrebbe essere copiabile sulle celle sottostanti.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Somma intervallo righe":


Chi c’è in linea

Visitano il forum: Nessuno e 11 ospiti