Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

sommare dati uguali excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

sommare dati uguali excel

Postdi CIACILLO1 » 22/01/11 10:45

ciao a tutti, ho un problema con un file excel ossia:
A B C D E F G H I L
1
2

nella colonna A inserisco dei codici dove viene riportata in B un anagrafica;
in C viene riportato il totale di D+E+F+G+H+I+L;
sin qui tutto ok,
il problema è quando vado ad inserire due codici uguali, vorrei che debbano essere sommati tutte e due le righe anche se devo usare due fogli o due griglie.
ringrazio in anticipo
CIACILLO1
Utente Junior
 
Post: 43
Iscritto il: 04/06/09 11:39

Sponsor
 

Re: sommare dati uguali excel

Postdi CANAPONE » 22/01/11 12:05

Ciao,

=MATR.SOMMA.PRODOTTO(($A$2:$A2=$A2)*D$2:L$2)

da copiare ed incollare in basso lungo la colonna B.

Solo per scrupolo, la formula somma progressivamente anche il contenuto delle colonne J e K.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: sommare dati uguali excel

Postdi CANAPONE » 22/01/11 12:11

Ciao,

mi è scappato un dollaro di troppo nel precedente post.

Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(($A$2:$A2=$A2)*D$2:L2)



Spero sia d'aiuto.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: sommare dati uguali excel

Postdi CIACILLO1 » 24/01/11 10:50

http://www.filedropper.com/b
ho allegato l'immagine così è più chiaro,
io vorrei che in B 10 venga riportato il valore doppio GIANNI con la somma dei valori doppi che sono in B 2 e in B 4.
aiutatemi......
CIACILLO1
Utente Junior
 
Post: 43
Iscritto il: 04/06/09 11:39

Re: sommare dati uguali excel

Postdi Anthony47 » 24/01/11 14:40

Metti i B10 (e sottostanti?) i nominativi di cui vuoi fare il riepilogo
Metti in C10 la formula
Codice: Seleziona tutto
=SOMMA.SE($B$1:$B$9;$B11;C$1:C$9)

Copia C10 nelle colonne adiacenti
Eventualmente copia C10:Q10 nelle righe sottostanti.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: sommare dati uguali excel

Postdi Flash30005 » 24/01/11 14:54

Prova questa macro

Codice: Seleziona tutto
Sub Elenco2()
For RR1 = 2 To 7
    Esiste = 0
    Nome1 = Range("B" & RR1).Value
    If Nome1 = "" Then Exit Sub
    For RR2 = 10 To 15
        Nome2 = Range("B" & RR2).Value
        If Nome2 = "" Then GoTo SaltaRR1
        If Nome1 = Nome2 Then Esiste = 1
    Next RR2
SaltaRR1:
    If Esiste = 0 Then Range("B" & RR2).Value = Nome1
Next RR1
Call Totali
End Sub
Sub Totali()
Range("C10:Q15").ClearContents
For RR2 = 10 To 15
    Nome2 = Range("B" & RR2).Value
    If Nome2 = "" Then GoTo SaltaRR2
    For RR1 = 2 To 7
        Nome1 = Range("B" & RR1).Value
        If Nome1 = "" Then GoTo SaltaRR2
        If Nome1 = Nome2 Then
            For CC2 = 3 To 15
                Cells(RR2, CC2).Value = Cells(RR2, CC2).Value + Cells(RR1, CC2).Value
            Next CC2
        End If
    Next RR1
SaltaRR2:
Next RR2
End Sub


Fai sapere
Ciao

Edit: Leggi il Post di Anthony che ho trovato dopo l'invio del mio post
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: sommare dati uguali excel

Postdi CIACILLO1 » 25/01/11 11:16

Grazie anthony, funziona perfettamente.
:)
siete grandi....
CIACILLO1
Utente Junior
 
Post: 43
Iscritto il: 04/06/09 11:39


Torna a Applicazioni Office Windows


Topic correlati a "sommare dati uguali excel":


Chi c’è in linea

Visitano il forum: Marius44 e 20 ospiti