Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Verificare 2 numeri

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Verificare 2 numeri

Postdi Scorte » 15/01/11 12:04

Ciao a tutti...
ho un lavoro da fare,e mi sono bloccato su una parte...
ho 5 numeri e devo verificare che la distanza di questi numeri sia 45 o -45 per far accendere l'ok
come faccio ?
es:
i numeri sono:
1 - 46 - 12 - 58 - 57
1 e 46 = 45 esito:OK
1 e 12 = no
1 e 58 = no
1 e 57 = no
46 e 12 = no
46 e 58 =no
46 e 57 =no
12 e 58 =no
12 e 57 = 45 esito:OK
58 e 57 = no

avevo pensato a es: (12+(-57)) che in effetti da -45 cioè l'esito è ok...
come faccioad aggiungere l'esito?se la formula fosse giusta?
Grazie
Scorte
Utente Junior
 
Post: 15
Iscritto il: 16/12/10 23:55

Sponsor
 

Re: Verificare 2 numeri

Postdi CANAPONE » 15/01/11 13:45

Ciao, forse basta
Codice: Seleziona tutto
=SE(ASS(A1-B1)=45;"Esito: OK"; "No")


oppure
Codice: Seleziona tutto
=SCEGLI((ASS(A1-B1)=45)+1;"No";"Esito: OK")


Spero di aver capito.

Saluti a tutti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Verificare 2 numeri

Postdi Scorte » 15/01/11 14:02

perfetto!!!
GRAZIE 1000 E qll che cercavo!!!
Scorte
Utente Junior
 
Post: 15
Iscritto il: 16/12/10 23:55

Re: Verificare 2 numeri

Postdi Scorte » 01/02/11 03:09

Scorte ha scritto:Ciao a tutti...
ho un lavoro da fare,e mi sono bloccato su una parte...
ho 5 numeri e devo verificare che la distanza di questi numeri sia 45 o -45 per far accendere l'ok
come faccio ?
es:
i numeri sono:
1 - 46 - 12 - 58 - 57
1 e 46 = 45 esito:OK
1 e 12 = no
1 e 58 = no
1 e 57 = no
46 e 12 = no
46 e 58 =no
46 e 57 =no
12 e 58 =no
12 e 57 = 45 esito:OK
58 e 57 = no

avevo pensato a es: (12+(-57)) che in effetti da -45 cioè l'esito è ok...
come faccioad aggiungere l'esito?se la formula fosse giusta?
Grazie


E fin qui abbiamo risolto...
es:
12 e 57 = 45 esito ok...
tramite un altro calcolo
ho un altro numero es : 10(num X)
e devo verificare che la somma di questi 2 numeri mi dai il n°X
es n° X 10
1°=8
2°= 90
3°=80
4°=2
5°=20
In questo caso 90 e 80 hanno distanza esatta del n° X quindi OK...test OK
e anche 8 e 2 hanno distanza del n° X test OK

Come faccio a verificare che quei 2 numeri mi dia la distanza esatta del n°X?
90 e 80
8 e 2
Grazie
Scorte
Utente Junior
 
Post: 15
Iscritto il: 16/12/10 23:55

Re: Verificare 2 numeri

Postdi CANAPONE » 01/02/11 05:00

Ciao,
se lavori con numeri positivi (esempio: numeri estratti), in A1 scrivi la distanza da controllare fra i due numeri.

Codice: Seleziona tutto
=SE(O(A2+B2=$A$1;ASS(A2-B2)=$A$1);"Ok";"No")


Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze


Torna a Applicazioni Office Windows


Topic correlati a "Verificare 2 numeri":


Chi c’è in linea

Visitano il forum: Nessuno e 11 ospiti