Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] riportare risultato Test

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] riportare risultato Test

Postdi iki » 04/12/10 18:07

premetto che non sapevo come intitolarlo, e che mi sono appena iscritto quindi vi saluto.

il mio problema.

sto riportando in excel dei Test da sottoporre a delle persone (tipo quelli di cioè ma un po' più ricchi di significato):

ad ogni domanda ci sono due risposte che hanno ciascuna una sotto risposta coincidente.

Es
che scuola Fai?

a) ITIS [C17]
privato [P18] tra parentesi le posizioni all'interno del foglio excel
pubblico [p19] scusate ma non saprei come farvi capire
b) Liceo [c20]

ora se rispondo
ITIS/privato il punteggio è 4
ITIS/pubblico il punteggio è 3
Liceo/privato il punteggio è 1
Liceo/pubblico il punteggio è 2

scusate l'esempio stupido, ma mi è venuto in mente questo.
ovviamente alla fine del test che prevede un po' di domanda dovrei fare la somma dei punteggi.
ho provato a risolverlo con questa formula [=SE(E(C17="x";P18="x");"4";"")] mettendo in quattro celle diverse le varie condizioni e cercando di fare la somma finale, ma non riconosce il valore.

c'è un modo più rapido? come fare a far riconoscere il punteggio come numero??

grazie mille in anticipo e scusate se non sono stato chiaro
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56

Sponsor
 

Re: [Excel] riportare risultato Test

Postdi alby60 » 04/12/10 18:43

Ciao, prova con =SE(E(C17="x";P18="x"); 4; 0)
alby60
Utente Junior
 
Post: 76
Iscritto il: 18/11/10 01:04

Re: [Excel] riportare risultato Test

Postdi iki » 04/12/10 18:48

ho già provato, il problema è che quando vado a fare la sommatoria, non mi restituisce il numero, ma mi segna "VALORE"

ho anche provato a cercare di farlo diventare un numero modificando la cella, ma nulla!! :mmmh:
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56

Re: [Excel] riportare risultato Test

Postdi iki » 04/12/10 18:52

mi correggo, non avevo visto l'assenza delle virgolette.

provato anche in questa manierea, ma la formula Non dà valore, ma lo segnala come errore.
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56

Re: [Excel] riportare risultato Test

Postdi alby60 » 04/12/10 22:17

Ciao, quale formula ti da errore, quella con cui fai la somma?
alby60
Utente Junior
 
Post: 76
Iscritto il: 18/11/10 01:04

Re: [Excel] riportare risultato Test

Postdi iki » 06/12/10 14:04

si,

questa formula [=SE(E(C17="x";P18="x"); "4"; "0")
mi genera correttamente i risultati; ad ogni domanda c'è accanto le quattro celle con le quattro soluzioni possibili ( e qui mi domandavo se potevo mettere in una cella soltanto le quattro soluzioni.

io arrvo ad ottenere una colonna con 3 risultati in 3 celle diverse (tante quante sono le domande del test)

Esempio
4
2
3

quando io vado a fare lo sommatoria per ottenere il punteggio massimo rilevato non mi genera nessuno numero, come se non lo rilevasse come numero, ma come dato scritto.
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56

Re: [Excel] riportare risultato Test

Postdi Flash30005 » 06/12/10 14:30

Ciao Iki e benvenuto nel Forum

La formula che proponi fornisce delle stringhe (testo) in quanto i numeri sono racchiusi tra virgolette ("4")
la formula fornita da Alby60 è corretta, se copi la formula vedrai che potrai fare le somme in quanto avrai dei numeri invece che caratteri testo

Per Alby60 sia le formule che i codici di macro andrebbero scritti con il Tag "Code" situato nell'editor del post
non usando il Tag è più facile sbagliare l'operazione di copia del codice.
Inserendo il tag Code si ha questa scrittura

Codice: Seleziona tutto
=SE(E(C17="x";P18="x"); 4; 0)

che permette di selezionare l'intero codice con l'apposito link (Seleziona Tutto) posto sopra al box

Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: [Excel] riportare risultato Test

Postdi iki » 06/12/10 14:53

GRAZIE MILLE ALBY, non avevo saputo sfruttare il tuo prezioso aiuto

caspita, avevo già fatto questa operazione solo che probabilmente avevo modificato la proprietà della colonna e non mi riconosceva la formula...

sarebbe possibile mettere più stringhe in una cella?
in modo da non avere 4 celle di risposta per ogni domanda?
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56

Re: [Excel] riportare risultato Test

Postdi alby60 » 07/12/10 00:26

Ciao
Flash3005, scusa mi era sfuggito l'utilizzo dei Tag-Code.
Iki cosa vuoi dire con
sarebbe possibile mettere più stringhe in una cella?
in modo da non avere 4 celle di risposta per ogni domanda?

Alby
alby60
Utente Junior
 
Post: 76
Iscritto il: 18/11/10 01:04

Re: [Excel] riportare risultato Test

Postdi iki » 07/12/10 14:43

volevo postare un immagine, ma non ne sono stato capace.

la formula
[=SE(E(C17="x";P18="x"); 4; 0)]

io devo inserirla in Quattro Celle diverse per avere tutte le possibilità di risposta

[=SE(E(C17="x";P19="x"); 3; "0")]
[=SE(E(C20="x";P18="x"); 2; "0")]
[=SE(E(C20="x";P19="x"); 1; "0")]

fatto questo, faccio una sommatoria per ogni risultato ottenuto da ciscuna domanda posta nel test ed ottengo il risultato finale.

il mio problema è risolto, MA volevo sapere se è possibile mettere in una sola cella, una stringa di comando che riassuma tutte e quattro le possibilità.

ho provato in varie sintassi, ma temo che mettere quattro SE in una cella sia impossibile.

mi sbaglio?

spero di essere stato più chiaro :roll:
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56

Re: [Excel] riportare risultato Test

Postdi Anthony47 » 09/12/10 00:21

Prova
Codice: Seleziona tutto
=SE(E(C17="x";P19="x");3;SE(E(C20="x";P18="x");2;SE(E(C20="x";P19="x");1;0)))

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] riportare risultato Test

Postdi iki » 10/12/10 13:53

Perfetto ! ! ! ! ! ! ! ! !


funziona, grazie mille
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56

Re: [Excel] riportare risultato Test

Postdi iki » 10/12/10 13:56

come faccio a modificare il titolo e mettere RISOLTO
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56

Re: [Excel] riportare risultato Test

Postdi Anthony47 » 11/12/10 00:25

come faccio a modificare il titolo e mettere RISOLTO
Non puoi modificare un post; ma non preoccuparti, tutte le nostre discussioni sono Risolte per definizione :D :D

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] riportare risultato Test":


Chi c’è in linea

Visitano il forum: Nessuno e 11 ospiti