Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Riferimento a file esterno Indiretto()

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Riferimento a file esterno Indiretto()

Postdi hayabusa_65 » 25/11/10 18:58

Sono ancora qui a chiedere un aiuto.
Gestisco un file per dei bilanci periodici che devo fare e che confronto con bilanci di periodi precedenti.
Utilizzo un file master che uso per ogni periodo e che poi salvo col nome del periodo di riferimento.
In un foglio richiamo i bilanci dei periodi precedenti con la funzione cerca verticale e con la seguente formula:
=SE.ERRORE(CERCA.VERT(STRINGA.ESTRAI(A6;3;7);'Y:\Controlli 2010\Bilancio al 06 2010\[bilancio coge.xls]Sheet1'!$A$2:$F$599;6;FALSO);0)

In pratica faccio cercare il conto di contabilità che si trova in A6 del foglio e vado a cercare il saldo di quel conto nel bilancio che si trova in 'Y:\Controlli 2010\Bilancio al 06 2010\[bilancio coge.xls]Sheet1'!$A$2:$F$599. nella colonna 6

Questo lo faccio per tre periodi precedenti.

ora io vorrei andare ad inserire il parametro 'Y:\Controlli 2010\Bilancio al 06 2010\[bilancio coge.xls]Sheet1'!$A$2:$F$599 in una cella che chiamerò "Bilancio_1" e sostituire la formula precedente con

=SE.ERRORE(CERCA.VERT(STRINGA.ESTRAI(A6;3;7);INDIRETTO(Bilancio_1);6;FALSO);0) cosicché ogni volta che faccio la situazione successiva non devo cambiare tutte le formule ma cambio solamente il valore di Bilancio_1

Tutto ciò sarebbe bello se funzionasse!!! :cry: , ma non funziona.
Mi potete dare una mano?
Grazie.
hayabusa_65
Utente Junior
 
Post: 29
Iscritto il: 18/10/10 10:43

Sponsor
 

Re: Riferimento a file esterno Indiretto()

Postdi Anthony47 » 26/11/10 00:13

Puoi usare Indiretto solo se il file target e' aperto, come detto anche nell' help on line di excel.

Ma guarda che se metti il nome file nella formula non devi andare a modificare tutte le formule: Menu /Modifica /Collegamenti; scegli il collegamento attuale, premi Cambia origine, scegli il nuovo collegamento.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13903
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Riferimento a file esterno Indiretto()

Postdi hayabusa_65 » 26/11/10 11:18

Ti ringrazio per il suggerimento.
In ogni caso, per capire come funziona la formula, io ho provato anche con il file origine apero ma non funzionava comunque.
In cosa sbaglio?
Ciao e grazie
hayabusa_65
Utente Junior
 
Post: 29
Iscritto il: 18/10/10 10:43

Re: Riferimento a file esterno Indiretto()

Postdi Anthony47 » 26/11/10 13:51

Dovresti pero' dire che cosa hai scritto esattamente nella cella chiamata Bilancio_1, copiando il contenuto dalla barra della formula e incollandola nel tuo messaggio; oltre che il messaggio di errore.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13903
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Riferimento a file esterno Indiretto()

Postdi hayabusa_65 » 29/11/10 15:27

Ti ringrazio per l'a risposta.
nella cella denominata Bilancio_1 ho scritto:
'Y:\Controlli 2010\Bilancio al 06 2010\[bilcoge.xls]Sheet1'!$a$2:$f$600 (ho fatto copia e incolla e quindi è esattamente questo)
e l'errore che mi ritorna è #RIF
Inoltre ti dico che se nella fomula nella quale inserisco la cella Bilancio_1
=SE.ERRORE(CERCA.VERT(STRINGA.ESTRAI(A6;3;7);INDIRETTO(Bilancio_1);6;FALSO);0)
sostituisco il riferimento diretto e la faccio diventare :
=SE.ERRORE(CERCA.VERT(STRINGA.ESTRAI(A8;3;7);'Y:\Controlli 2010\Bilancio al 06 2010\[bilcoge.xls]Sheet1'!$a$2:$f$600;6;FALSO);0) la formula funziona.

Ciao e grazie
hayabusa_65
Utente Junior
 
Post: 29
Iscritto il: 18/10/10 10:43

Re: Riferimento a file esterno Indiretto()

Postdi Anthony47 » 30/11/10 22:51

Scusa, mi era sfuggita la tua risposta.
L' apostrofo iniziale in realta' viene interpretato da excel come "indicatore di testo", pertanto nella cella esso manca; per questo inserirai un secondo apostrofo in testa, in aggiunta a quello attualmente presente.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13903
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Riferimento a file esterno Indiretto()":


Chi c’è in linea

Visitano il forum: Zer0Kelvin e 5 ospiti