Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel] Funzioni di ricerca e riferimento

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel] Funzioni di ricerca e riferimento

Postdi biancocandido55 » 16/10/10 16:55

Un cordiale saluto a tutti :),
ragazzi ho traslato le tavole di Rutilio su un foglio,
dopo aver fatto una serie di calcoli, non riesco a venirne a capo con alcune funzioni di ricerca e riferimento:
come da Immagine
I valori in rosso fuori tabella
A = cella L4 (numero tavola), nella 1ª riga della tabella R2 a EC14
e
B = cella P3 (mese, nella colonna R da R3:R14
nelle celle da J9 a O9 ci sono i 6 risultati (momentaneamente inseriti a mano) che dovrebbero comparire con le funzioni che mi occorrono.
Ringrazio anticipatamente,
un abbraccio
bianco55Immagine
biancocandido55
Utente Senior
 
Post: 305
Iscritto il: 03/03/06 10:15

Sponsor
 

Re: [excel] Funzioni di ricerca e riferimento

Postdi Anthony47 » 16/10/10 19:21

Sulla base dell' immagine postata, in J9:
Codice: Seleziona tutto
=INDICE($R2:$AQ14;CONFRONTA($P$3;$R2:$R14;0);CONFRONTA($L$4;$R2:$AQ2;0)-6+RIF.COLONNA(A1))

Poi copia verso dx.
Nelle formule metterai al posto di $AQ la vera colonna di fine della tua tabella.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [excel] Funzioni di ricerca e riferimento

Postdi Flash30005 » 16/10/10 19:28

Prova questa macro nel modulo
Codice: Seleziona tutto
Sub RicercaV()
UC = Range("IV4").End(xlToLeft).Column
NVR = Range("P3").Value
NVC = Range("L4").Value
If NVC > Int((UC - 19) / 6) Then
MsgBox "Inserisci un valore di tabella esistente"
GoTo esci
End If
For RR = 4 To 15
If NVR = Range("R" & RR).Value Then Riga = RR
Next RR
For VR = 1 To 6
Cells(10, 9 + VR).Value = Cells(Riga, 19 + VR + (NVC - 1) * 6).Value
Next VR
esci:
End Sub

E questo codice nel Foglio dei dati
Codice: Seleziona tutto
Private Sub Worksheet_Change(ByVal Target As Range)
CheckArea = "L4, P3"
If Not Application.Intersect(Target, Range(CheckArea)) Is Nothing Then
Call RicercaV
End If
End Sub

Al variare di uno dei due valori (L4 o P3) otterrai il risultato voluto

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: [excel] Funzioni di ricerca e riferimento

Postdi biancocandido55 » 16/10/10 21:05

Ciao Anthony, ciao Flash,
un grazie 100.000 per le 2 soluzioni,
come sempre, un abbraccio
bianco55 Immagine
biancocandido55
Utente Senior
 
Post: 305
Iscritto il: 03/03/06 10:15


Torna a Applicazioni Office Windows


Topic correlati a "[excel] Funzioni di ricerca e riferimento":


Chi c’è in linea

Visitano il forum: Nessuno e 14 ospiti