Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

help formule e macro per programma fantacalcio

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Re: help formule e macro per programma fantacalcio

Postdi Flash30005 » 17/10/10 02:38

Nel post del 13/10/10 09:28 avevi detto:

gigilatrottola ha scritto:http://www.megaupload.com/?d=KI2RZLXH
questo e il file corretto , senza l'unione delle celle,


In questo file
gigilatrottola ha scritto:ecco il file......
http://www.megaupload.com/?d=OI9S6A08

Tutte le rose sono su celle unite (es. vedi Rizla occupa 3 colonne e 2 righe)
(avevamo un post apposito contro le celle unite :roll: )

e l'ultimo file da te inviato non ha alcuna macro
(del tipo da me creata per avere le rose come le volevi precedentemente)

Se continui a cambiare le specifiche di cosa vorresti ottenere significa che non hai chiara la meta da raggiungere
e, in questo caso, come pensi possiamo aiutarti?
rileggi questo post

Perdere inutilmente tempo penso sia la cosa peggiore che possa fare un essere umano e se non è così per tutti per me lo è!

Specifica meglio il tuo quesito, sistema il tuo file, chiedi con chiarezza e troverai sempre utenti disponibili a risolvere il tuo quesito
Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Sponsor
 

Re: help formule e macro per programma fantacalcio

Postdi gigilatrottola » 17/10/10 07:44

hai ragione Flash30005, il fatto che ho cambiato più volte e dovuto anche al fatto che mettendo in pratica le mie idee con le tue soluzioni alla fine non sono servite per un miglior utilizzo. ti invierò alla fine il file completo, con tutte le macro create.
scusami se ti ho fatto perdere tempo, ma di certo non era nelle mie intenzioni.

x Anthony47
Ho provato a guardare il file, ma vedo che tutti i voti sono dei valori digitati nelle celle, quindi non capisco la richiesta di mettere automaticamente i voti per le riserve qualora non giochino i titolari (almeno cosi' ho interpretato il tuo messaggio).
Se quindi non ti arriveranno risposte ti chiedero' qualche chiarimento sulla logica da realizzare.


praticamente dove stanno tutti i dati digitati sono stati messi li manualmente solo x inviare il file, in quello originale ho una macro che copia ed incolla i voti , ma vorrei creare una formula o macro che metta i voti delle riserve come ho spiegato nel post precedente.
se hai bisogno del file originale, fammi sapere.......

una volta finito il tutto c'è un modo x proteggere le formule x non modificarle erroneamente e non renderle visibili?
grazie ancora e buona domenica a tutti.
gigilatrottola
Utente Senior
 
Post: 184
Iscritto il: 10/06/06 09:58

Re: help formule e macro per programma fantacalcio

Postdi gigilatrottola » 17/10/10 08:00

come vedi c'è una macro con ordina x t cosi mette tutti i titolari in alto ed i panchinari in ordine numerico
poi c'è invia t, fa il copia ed incolla i titolari nelle prime 11 caselle e i 6/7 panchinari sotto, questo per ogni squadra.
pi c'è un'altra macro , invia formazioni, che copia ed incolla tutto quello che c'è nelle caselle AM1-BN47 aprendo un'altro foglio excel incollando le formazioni e chiudendosi e salvandosi sul desktop (a proposito quando copio ed incollo 2 volte, esempio prima le formazioni e poi la classifica , che sta in un altro foglio, mi da un errore),
poi c'è l'ultima macro , invia voti, che praticamente copia i voti (dove stanno digitati manualmente).

questo è il file.....
http://www.megaupload.com/?d=C6GA0EUV


le macro nell'altro file nn le ho messe perchè come queste nn erano funzionanti (dato che ci voleva troppo tempo x ri-farle da capo)...... ma che nel file originale funzionano perfettamente.
gigilatrottola
Utente Senior
 
Post: 184
Iscritto il: 10/06/06 09:58

Re: help formule e macro per programma fantacalcio

Postdi gigilatrottola » 22/10/10 13:44

help me, please......

ho bisogno di questa formula .......
grazie in anticipo....
gigilatrottola
Utente Senior
 
Post: 184
Iscritto il: 10/06/06 09:58

Re: help formule e macro per programma fantacalcio

Postdi Anthony47 » 23/10/10 01:50

Allora, senza altre informazioni che non i voti espressi o non espressi nella seconda colonna delle votazioni dei titolari (anche se mi pare che ci sia una R nelle posizioni da colmare), in BB15 (quindi riferita alla squadra Quagliarella) metti la formula
Codice: Seleziona tutto
=SE(E(SOMMA((BB$3:BB$13="-")*(AY$3:AY$13=AY15))>0;SOMMA((BB$3:BB$13="-")*(AY$3:AY$13=AY15))>=SOMMA((AY$15:AY15=AY15)*(BA$15:BA15<>"-")));SE(BA15<>"-";BA15;"");"")
che confermerai con Contr-Maiusc-Enter; poi copia verso il basso nelle altre posizioni delle riserve.
Copia poi BB15:BB21 nelle colonne delle altre squadre "superiori" (righe 1-22).
Per le squadre "inferiori" devi adattare gli indirizzi mantenendo la sintassi.

I voti non espressi sono quelli indicati con "-", mentre per me lo "zero" e' un voto espresso. Non faccio nessuna verifica che, ad esempio, se 3 centrocampisti titolare non hanno voto siano disponibili 3 voti tra i centrocampisti di riserva.

Per quanto riguarda la protezione delle formule dalla loro modifica involontaria, basta proteggere il foglio.

Ciao, fai sapere.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: help formule e macro per programma fantacalcio

Postdi gigilatrottola » 23/10/10 23:09

la formula funziona perfettamente, ci sono solo 2 problemi , il primo è che non rispetta il max delle sosituzioni (cioè 3 ) e purtroppo quella un pochino + difficoltosa, che oltre al "-" dovrebbe mettere il voto anche allo "0"......

buona domenica a tutti.....
gigilatrottola
Utente Senior
 
Post: 184
Iscritto il: 10/06/06 09:58

Re: help formule e macro per programma fantacalcio

Postdi Anthony47 » 24/10/10 15:46

Per il secondo problema puoi modificare la formula che ti diedi per BB15 in
Codice: Seleziona tutto
=SE(E(SOMMA(((BB$3:BB$13="-")+(BB$3:BB$13=0))*(AY$3:AY$13=AY15))>0;SOMMA(((BB$3:BB$13="-")+(BB$3:BB$13=0))*(AY$3:AY$13=AY15))>=SOMMA((AY$15:AY15=AY15)*((BA$15:BA15<>"-")*(BA$15:BA15<>0))));SE(E(BA15<>"-";BA15<>0);BA15;"");"")
Poi operi come detto.

Per il primo problema, la formula prova a inserire il punteggio di una riserva per ogni titolare privo di punteggio, rispettando il ruolo e se trova una riserva con punteggio. Non so cosa intendi con " non rispetta il max delle sosituzioni", prova a spiegare in termini di excel non di fantacalcio.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: help formule e macro per programma fantacalcio

Postdi gigilatrottola » 24/10/10 22:36

inutile dirlo che la formula funziona pefettamente,
per l'ultimo problema allora ti spiego meglio .....
la formula che hai fatto praticamente mette il voto al giocatore in panchina quando uno dei titolari non prende il voto , cioè o "-" oppure "0".(logicamente rispettando il ruolo)
il mio problema sta nel fatto che se ci fossero 4 giocatori titolari che non prende il voto, la formula permette di mettere il voto a 4 panchinari, ecco il problema è quello, massimo ci possono essere 3 sostituzioni, quindi in caso di 4 o più titolari che non giocano, la formula dovrebbe mettere il voto al massimo a 3 panchinari, sempre rispettando il ruolo.
per spiegarmi ancora meglio, excel parlando, prendento in esame l'ultimo file che ho allegato a questo topic,
consideriamo la sqaudra el principito: ha quattro giocatori con "-" o "0" (BB29 maicon, BB30 nesta, BB34 vargas, BB36 ibrahimovic) la fromula deve fare in modo da mettere il voto solo a tre panchinari e cioè BB39 (del piero) BB41 (Guberti) e BB43 (andreolli) , mentre a Cassani BB 44 non deve prenderlo in considerazione.

forse con un "conta se" si potrebbe fare qualcosa, oppure ho detto un'altra cavolata?

buona notte a tutti.
gigilatrottola
Utente Senior
 
Post: 184
Iscritto il: 10/06/06 09:58

Re: help formule e macro per programma fantacalcio

Postdi Anthony47 » 25/10/10 17:21

Modifica la formula in BB15:
Codice: Seleziona tutto
=SE(E(SOMMA(((BB$3:BB$13="-")+(BB$3:BB$13=0))*(AY$3:AY$13=AY15))>0;SOMMA(((BB$3:BB$13="-")+(BB$3:BB$13=0))*(AY$3:AY$13=AY15))>=SOMMA((AY$15:AY15=AY15)*((BA$15:BA15<>"-")*(BA$15:BA15<>0))));SE(E(BA15<>"-";BA15<>0;CONTA.SE(BB$14:BB14;">0")<3);BA15;"");"")

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: help formule e macro per programma fantacalcio

Postdi gigilatrottola » 26/10/10 16:46

fantasctico......
funziona perfettamente....
ti ringrazio tantissimo della tua disponibilità....

grazie ancora......
gigilatrottola
Utente Senior
 
Post: 184
Iscritto il: 10/06/06 09:58

Re: help formule e macro per programma fantacalcio

Postdi scirea1976 » 08/11/10 05:04

Salve a tutti.. e complimenti !!!
avrei bisogno di un aiutino , mi servirebbe la stessa formula postata in precedenza della cella BB15 con qualche variazione.
1) le sostituzioni dei giocatori devono avvenire solo se hanno ottenuto solo il simbolo "-" e non lo "0" in quanto lo zero ("0") potrebbe essere un voto.
2) vorrei far contare alla formula anche il simbolo "-" ( mi spiego meglio se un giocatore non gioca e ottiene "-" vorrei che sia contata come sostituzione) ... fermo restando che le sostituzioni possibili sono 3 .... quindi anche un panchinaro che non prende voto dovrebbe valere come sostituzione..
spero di essere stato chiaro.... grazie
scirea1976
Utente Junior
 
Post: 21
Iscritto il: 08/11/10 04:44

Re: help formule e macro per programma fantacalcio

Postdi scirea1976 » 08/11/10 13:16

Qualcuno può aiutarmi ??
scirea1976
Utente Junior
 
Post: 21
Iscritto il: 08/11/10 04:44

Re: help formule e macro per programma fantacalcio

Postdi Anthony47 » 09/11/10 00:33

Ciao scirea1976 e benvenuto nel forum.
Quello che chiedi al punto 1 corrisponde alla formula di un paio di messaggi fa; userai:
Codice: Seleziona tutto
=SE(E(SOMMA(((BB$3:BB$13="-"))*(AY$3:AY$13=AY15))>0;SOMMA(((BB$3:BB$13="-"))*(AY$3:AY$13=AY15))>=SOMMA((AY$15:AY15=AY15)*((BA$15:BA15<>"-"))));SE(E(BA15<>"-";CONTA.NUMERI(BB$14:BB14)<3);BA15;"");"")
Sempre Contr-Maiusc-Enter
Per il punto 2, intendi dire che quindi si prendono i primi panchinari, considerando il ruolo ma sostanzialmente ignorando il punteggio attibuito?

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: help formule e macro per programma fantacalcio

Postdi scirea1976 » 09/11/10 00:48

Anthony47 ha scritto:Ciao scirea1976 e benvenuto nel forum.
Quello che chiedi al punto 1 corrisponde alla formula di un paio di messaggi fa; userai:
Codice: Seleziona tutto
=SE(E(SOMMA(((BB$3:BB$13="-"))*(AY$3:AY$13=AY15))>0;SOMMA(((BB$3:BB$13="-"))*(AY$3:AY$13=AY15))>=SOMMA((AY$15:AY15=AY15)*((BA$15:BA15<>"-"))));SE(E(BA15<>"-";CONTA.NUMERI(BB$14:BB14)<3);BA15;"");"")
Sempre Contr-Maiusc-Enter
Per il punto 2, intendi dire che quindi si prendono i primi panchinari, considerando il ruolo ma sostanzialmente ignorando il punteggio attibuito?

Ciao


considerando sempre il ruolo , dovrebbe contare massimo tre sostituzioni considerando anche quelle riserve che hanno preso "-" ,invece la formula mi conta ai fini delle 3 sostituzioni solo le riserve che hanno un voto ( tipo 5 o 6 ecc).
ciaooo e grazie :D
scirea1976
Utente Junior
 
Post: 21
Iscritto il: 08/11/10 04:44

Re: help formule e macro per programma fantacalcio

Postdi scirea1976 » 09/11/10 02:01

Anthony47 ha scritto:Ciao scirea1976 e benvenuto nel forum.
Quello che chiedi al punto 1 corrisponde alla formula di un paio di messaggi fa; userai:
Codice: Seleziona tutto
=SE(E(SOMMA(((BB$3:BB$13="-"))*(AY$3:AY$13=AY15))>0;SOMMA(((BB$3:BB$13="-"))*(AY$3:AY$13=AY15))>=SOMMA((AY$15:AY15=AY15)*((BA$15:BA15<>"-"))));SE(E(BA15<>"-";CONTA.NUMERI(BB$14:BB14)<3);BA15;"");"")
Sempre Contr-Maiusc-Enter
Per il punto 2, intendi dire che quindi si prendono i primi panchinari, considerando il ruolo ma sostanzialmente ignorando il punteggio attibuito?

Ciao

si.. qualsiasi voto hanno devono essere considerati come sostituzioni (anche se hanno voto nullo "-")
scirea1976
Utente Junior
 
Post: 21
Iscritto il: 08/11/10 04:44

Re: help formule e macro per programma fantacalcio

Postdi gigilatrottola » 09/11/10 09:38

ragazzi ho un'altro quesito da porvi......

non so se devo usare uncerca verticale, orizzontale o un se....e per questo chiedo un Vs supporto.....

devo mettere automaticamente , con una formula , le giornate da giocare in ogni singolo foglio, mi spiego meglio, nel foglio 1^ nella cella R14 c'è la prima giornata (presa dal foglio calendario A14)
di solito copio/incollo singolarmente le giornate nei foglio 2^ - 3^ - 4^ etc etc.....
mi date una mano a creare questa formula così in base al numero di giornata lui automaticamente mi va a mettere la giornata da giocare.......


ps mi rendo conto che come sempre ho scritto con i piedi....ma credo che mi avete capito....
grazie

http://www.megaupload.com/?d=8CEOGGLV
gigilatrottola
Utente Senior
 
Post: 184
Iscritto il: 10/06/06 09:58

Re: help formule e macro per programma fantacalcio

Postdi Anthony47 » 09/11/10 14:21

Per scirea: prova questa
Codice: Seleziona tutto
=SE(E(SOMMA(((BB$3:BB$13="-"))*(AY$3:AY$13=AY15))>0;SOMMA(((BB$3:BB$13="-"))*(AY$3:AY$13=AY15))>=SOMMA((AY$15:AY15=AY15)*((BA$15:BA15<>"+-"))));SE(E(BA15<>"+-";SOMMA(--(LUNGHEZZA(BB$14:BB14)>0))<3);BA15;"");"")
Non e' ottimizzata ma dovrebbe funzionare; ricorda Contr-Maiusc-Enter

Per gigilatrottola:
secondo me la cosa piu' semplice e' che copi da Calendario nei singoli fogli; nell' arco di una stagione non e' uno sfrorzo sovrumano.
Alternativamente:
-assegni ai nomi la stessa desinenza che hai usato in Calendario, cioe ' 1A, 2A, etc (invece che 1^, 2^, etc)
-vai su foglio 1° e inserisci in R15 la formula
Codice: Seleziona tutto
=SCARTO(calendario!$A$1;CONFRONTA("Campionato: "&STRINGA.ESTRAI(CELLA("nomefile");TROVA("]";CELLA("nomefile"))+1;99);calendario!$A:$A;0)+RIF.RIGA(A1)-1;RIF.COLONNA(A1)-1)
-copi R15; selezioni R15:S19; tenendo pigiato Shift (Maiusc) selezioni il tab dell' ultimo foglio di giornata (4A nell' esempio, oppure 36A se il file e' completo; tutti i fogli sembreranno selezionati); fai Contr-v per incollare la formula.
-vai nell' editor del vba; nella finestra Progetto - VBAProject fai doppioclick sulla voce ThisWorkbook; inserisci questa macro:
Codice: Seleziona tutto
Private Sub Workbook_SheetActivate(ByVal Sh As Object)
Calculate
End Sub
Tieni presente pero' che quando hai attivo un qualsiasi foglio, su tutti i fogli saranno in quel momento presenti le stesse formazioni; non so quanto questo ha impatto sulla tua architettura dati.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: help formule e macro per programma fantacalcio

Postdi scirea1976 » 09/11/10 14:46

Anthony47 ha scritto:Per scirea: prova questa
Codice: Seleziona tutto
=SE(E(SOMMA(((BB$3:BB$13="-"))*(AY$3:AY$13=AY15))>0;SOMMA(((BB$3:BB$13="-"))*(AY$3:AY$13=AY15))>=SOMMA((AY$15:AY15=AY15)*((BA$15:BA15<>"+-"))));SE(E(BA15<>"+-";SOMMA(--(LUNGHEZZA(BB$14:BB14)>0))<3);BA15;"");"")
Non e' ottimizzata ma dovrebbe funzionare; ricorda Contr-Maiusc-Enter

adesso provo se fila tutto poi ti faro sapere .. grazie.
scirea1976
Utente Junior
 
Post: 21
Iscritto il: 08/11/10 04:44

Re: help formule e macro per programma fantacalcio

Postdi scirea1976 » 09/11/10 15:21

Anthony purtroppo la formula non si comporta come vorrei io :( , ti posto un file dove ho messo la tua formula :lol: (esattamente nelle celle che vanno da E5 a E21), a sinistra ho elencato quello che praticamente vorrei ottenere, spero di essere stato chiaro, ciao e grazie infinite :P
Questo è il file
http://www.realfanta2009.altervista.org/scirea.xls
scirea1976
Utente Junior
 
Post: 21
Iscritto il: 08/11/10 04:44

Re: help formule e macro per programma fantacalcio

Postdi Anthony47 » 10/11/10 14:22

Nel tuo esempio hai titolari senza voto un P, un D e un C; la formula ti inserisce una riserva P, una D e una C.
Dove e' l' errore?

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

PrecedenteProssimo

Torna a Applicazioni Office Windows


Topic correlati a "help formule e macro per programma fantacalcio":


Chi c’è in linea

Visitano il forum: patel e 20 ospiti