Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

correttivo su funzione Excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

correttivo su funzione Excel

Postdi libraio » 26/08/10 14:23

Ciao a tutti,
chiedo il vs. aiuto perchè vorrei sapere come intervenire sulla funzione:

=SE(VAL.ERRORE(CERCA.VERT(A2;Foglio1!$A$1:$Z$10000;8;0));"";CERCA.VERT(A2;Foglio1!$A$1:$Z$10000;8;0))

in modo che mi restituisca un messaggio da me selezionato i partenza (es. ASSENTE, INSERITO, FUORI COMMERCIO, ecc.) anzichè il testo/valore inserito nella colonna selezionata.

Grazie per l'aiuto!
libraio
libraio
Utente Senior
 
Post: 211
Iscritto il: 04/01/10 20:31

Sponsor
 

Re: correttivo su funzione Excel

Postdi pietrol » 26/08/10 16:16

Ciao libraio
potrebbe essere
=SE(VAL.ERRORE(CERCA.VERT(A2;Foglio1!$A$1:$Z$10000;8;0));"ASSENTE";"INSERITO")
ma in base a cosa la funzione può capire se un articolo è ASSENTE o FUORI COMMERCIO?

Fai sapere

ciao
pietrol
il lupo ululà, il castello ululì
pietrol
Utente Senior
 
Post: 270
Iscritto il: 07/01/09 14:34

Re: correttivo su funzione Excel

Postdi libraio » 26/08/10 18:52

Grazie per il contributo.
Effettivamente la mia esposizione non era molto chiara...
Mettendo a confronto i dati inclusi in 2 fogli e scelta come matrice la colonna A di ogni foglio, se A2 (ed a seguire tutte le celle A) del Foglio 2 trova una corrispondenza in colonna A del Foglio 1, nella cella in cui applico la funzione vorrei che comparisse la dicitura prescelta (ASSENTE, INSERITO, FUORI CATALOGO, ecc).

Il mio problema è che non so come ed in quale parte della funzione debba inserire la dicitura prescelta :oops:

libraio
libraio
Utente Senior
 
Post: 211
Iscritto il: 04/01/10 20:31

Re: correttivo su funzione Excel

Postdi pietrol » 26/08/10 22:21

Ciao libraio
continuo a non capire:
se l'articolo esiste immagino vorrai INSERITO
se l'articolo esiste immagino vorrai ASSENTE
non riesco ad immaginare quando ci vuole FUORI CATALOGO.
Ma invece di farlo immaginare a me perchè non lo spieghi tu che lo sai?
Poi, dopo che è chiaro questo, qui c'è un sacco di persone in grado di spiegarti come far comparire la dicitura giusta.

ciao
pietrol
il lupo ululà, il castello ululì
pietrol
Utente Senior
 
Post: 270
Iscritto il: 07/01/09 14:34

Re: correttivo su funzione Excel

Postdi pietrol » 26/08/10 22:23

Scusate mi sono perso un "non" che ci voleva

se l'articolo esiste immagino vorrai INSERITO
se l'articolo NON esiste immagino vorrai ASSENTE
ecc. ecc.

pietrol
il lupo ululà, il castello ululì
pietrol
Utente Senior
 
Post: 270
Iscritto il: 07/01/09 14:34

Re: correttivo su funzione Excel

Postdi libraio » 28/08/10 11:54

Hai perfettamente ragione Pietrol solle mie spiegazioni "confuse"...
Ma il tuo ultimo post mi viene in soccorso ed esemplifica la mia richiesta.
Ok per il termine da inserire nella cella, se l'articolo esiste, ma se l'articolo non esiste vorrei che la cella restasse vuota: qual è la sintassi da scrivere per la cella vuota?
(Sarò riuscito a spiegarmi?...)
grazie ancora
libraio
Utente Senior
 
Post: 211
Iscritto il: 04/01/10 20:31

Re: correttivo su funzione Excel

Postdi pietrol » 28/08/10 14:04

Ciao libraio
prova così
=SE(VAL.ERRORE(CERCA.VERT(A2;Foglio1!$A$1:$Z$10000;8;0));"";"INSERITO")

ciao
pietrol
il lupo ululà, il castello ululì
pietrol
Utente Senior
 
Post: 270
Iscritto il: 07/01/09 14:34

Re: correttivo su funzione Excel

Postdi libraio » 28/08/10 18:30

Grazie Pietrol,
non potevo sperare di meglio; la tua soluzione risponde perfettamente alle mie esigenze :)
libraio
libraio
Utente Senior
 
Post: 211
Iscritto il: 04/01/10 20:31


Torna a Applicazioni Office Windows


Topic correlati a "correttivo su funzione Excel":


Chi c’è in linea

Visitano il forum: Zer0Kelvin e 14 ospiti