Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel.2003] Risultati Calcio

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel.2003] Risultati Calcio

Postdi gladiosannita » 21/08/10 10:53

Ciao a tutti
Avrei bisogno di un vostro aiuto,sto compilando un foglio excel con risultati delle partite di calcio,ora mettiamo che la
cella A1 sia = 1 e nella B1 sia = 0, mi servirebbe che nella la C3 sia = "NoGol" oppure,
cella A1 sia = 0 e nella B1 sia = 1, "NoGol"
cella A1 sia = 0 e nella B1 sia = 0, "Nulla"
tutti gli altri risultati,che non sia presente lo zero= "Gol"


Grazie
gladiosannita
Utente Junior
 
Post: 56
Iscritto il: 13/04/09 12:32

Sponsor
 

Re: [Excel.2003] Risultati Calcio

Postdi Karistotele » 21/08/10 12:32

Prova:

Codice: Seleziona tutto
=SE(O(E(A1=1;B1=0);E(A1=0;B1=1));"NoGoal";SE(E(A1=0;B1=0);"Nulla";SE(O(A1<>0;B1<>0);"Goal")))
.K
Avatar utente
Karistotele
Utente Junior
 
Post: 45
Iscritto il: 01/05/10 06:28
Località: PADOVA

Re: [Excel.2003] Risultati Calcio

Postdi gladiosannita » 21/08/10 12:51

Ciao Karistotele
Grazie x la risposta ma purtroppo non funziona....
gladiosannita
Utente Junior
 
Post: 56
Iscritto il: 13/04/09 12:32

Re: [Excel.2003] Risultati Calcio

Postdi gladiosannita » 21/08/10 13:30

:o Forse ho trovato la causa xchè le formule non vanno,magari xchè le celle dove dovrebbe prelevare i dati, a loro volta,ci sono inserite formule,mi spiego:
il calendario delle partite l'ho importo da pagina web,solo che il risultato della partita è in un unica cella es : A1= 1-0,
siccome poi dovrò calcolare alcune statistiche(x le scommesse),come appunto gol,nogol pari,dispari segni 1x2,under over ecc..x semplicare divido il risultato in due celle con questa formula:
Codice: Seleziona tutto
=SE(SINISTRA(B1;(LUNGHEZZA(B1)-(RICERCA("-";A1)*1))))

cambiando poi in DESTRA ,x l'altro risultato,avendo così in B1=1 e C1=0,e fin qui tutto ok, ma,sia con la formula di Karistotele :
Codice: Seleziona tutto
=SE(O(E(A1=1;B1=0);E(A1=0;B1=1));"NoGoal";SE(E(A1=0;B1=0);"Nulla";SE(O(A1<>0;B1<>0);"Goal")))

che con questa :
Codice: Seleziona tutto
=SE(E(A1=0;B1=0);"Nulla";SE(E(A1>0;B1>0);"Goal";"NOGoal")))

:mmmh: Non Funzionano,Invece se immeto da tastiera nelle due celle A1=1,e B1=0 ,entrambe le formule funzionano....
gladiosannita
Utente Junior
 
Post: 56
Iscritto il: 13/04/09 12:32

Re: [Excel.2003] Risultati Calcio

Postdi Karistotele » 21/08/10 15:10

Era meglio se specificavi prima.

Comunque ...
in A1 hai 1-0 in forma testuale.

Scrivi in B1:
Codice: Seleziona tutto
=--SINISTRA(ANNULLA.SPAZI(A1);1)


Digita in C1:
Codice: Seleziona tutto
=--DESTRA(ANNULLA.SPAZI(A1);1)


Formula finale:
Codice: Seleziona tutto
=SE(O(E(B1=1;C1=0);E(B1=0;C1=1));"NoGoal";SE(E(B1=0;C1=0);"Nulla";SE(O(B1<>0;C1<>0);"Goal")))


ANNULLA.SPAZI è un controllo di sicurezza per eventuali spazi "non a vista".

Fai sapere se e come hai risolto.
.K
Avatar utente
Karistotele
Utente Junior
 
Post: 45
Iscritto il: 01/05/10 06:28
Località: PADOVA

Re: [Excel.2003] Risultati Calcio

Postdi gladiosannita » 21/08/10 20:14

Grazie 1000 Karistotele

:lol: funziona tutto perfettamente!! come detto nel tuo ultimo aiuto.

ciao...
gladiosannita
Utente Junior
 
Post: 56
Iscritto il: 13/04/09 12:32

Re: [Excel.2003] Risultati Calcio

Postdi Karistotele » 22/08/10 05:23

Ti ringrazio per il riscontro.
Ciao
.K
Avatar utente
Karistotele
Utente Junior
 
Post: 45
Iscritto il: 01/05/10 06:28
Località: PADOVA


Torna a Applicazioni Office Windows


Topic correlati a "[Excel.2003] Risultati Calcio":


Chi c’è in linea

Visitano il forum: alfrimpa, enrico43 e 3 ospiti