Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

spostare celle righe pari in righe dispari Excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

spostare celle righe pari in righe dispari Excel

Postdi libraio » 26/07/10 11:49

Ciao a tutti,
ho un foglio con diverse righe di dati alfanumerici estratti da un elenco .txt
I dati sono divisi su due righe ed io vorrei sistemarli su unica riga, penso che sia quindi necessaria una macro (che non so scrivere...)
In pratica:
i dati contenuti nelle righe pari (colonne A:n) andrebbero spostati sulla colonna immediatamente superiore a partire dalla colonna G;
il "must" sarebbe eliminare contestualmente le righe pari, rimaste vuote; ma su questa azione posso intervenire manualmente in seconda battuta.
Grazie per l'aiuto
libraio
libraio
Utente Senior
 
Post: 211
Iscritto il: 04/01/10 20:31

Sponsor
 

Re: spostare celle righe pari in righe dispari Excel

Postdi Anthony47 » 26/07/10 19:50

Con formule:
-i tuoi dati sono in Foglio1, da riga 2 in giu'
-in altro foglio, sulla prima riga dove vuoi i risultati, es in A2, usi la formula
Codice: Seleziona tutto
=SE(RIF.COLONNA()<7;SCARTO(Foglio1!$A$2;2*(RIF.RIGA(A1)-1);RIF.COLONNA()-1);SCARTO(Foglio1!$A$2;1+2*(RIF.RIGA(A1)-1);RIF.COLONNA()-7))

-copi A2 verso destra fino a T2, poi copi A2:T2 verso il basso per quante righe ti serve

Nella formula, Foglio1!$A$2 rappresenta l' origine dei dati; se l' origine e' diversa (es i dati partono gia' da A1), adegua la formula.

Questo sulla base di quanto hai scritto, cioe' che vuoi prendere 6 colonne dalla prima righe di dati e affiancargli 14 colonne dalla riga successiva.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: spostare celle righe pari in righe dispari Excel

Postdi libraio » 05/08/10 20:31

Sono rientrato solo oggi al lvoro e, seppure in ritardo :oops: ,
voglio ringraziare Anthony per la (sua..) immediata risposta che, ancora una volta, mi ha risolto un problema.
Grazie :)
libraio
libraio
Utente Senior
 
Post: 211
Iscritto il: 04/01/10 20:31


Torna a Applicazioni Office Windows


Topic correlati a "spostare celle righe pari in righe dispari Excel":


Chi c’è in linea

Visitano il forum: Nessuno e 17 ospiti

cron