Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel trasformare un numero in X

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel trasformare un numero in X

Postdi Statix » 11/07/10 18:29

Ciao a tutti,
dovrei trasformare dei numeri in x,sia in formule che una macro va bene,
faccio un esempio
in Range B5:Y5 ho una serie di numeri tipo 3-5-7-2-1-1-1
dovrei fare in modo se in B5 c'è 3
in B10 = x
in B11 = x
in B12 = x
altro esempio in C5 c'è 5
C10 = x
C11 = x
C12 = x
C13 = x
C14 = x
quindi tante x in colonna
e cosi per le altre celle
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Sponsor
 

Re: Excel trasformare un numero in X

Postdi Statix » 11/07/10 18:48

Chiedo scusa,
me lo aveva chiesto un amico,ma ho
capito male cosa voleva fare.
quindi non serve più.
grazie :oops: :oops:
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Excel trasformare un numero in X

Postdi maxmula » 12/07/10 08:53

Comunque sia, una risposta te la becchi lo stesso :P

Basta mettere nelle celle a fianco a quella da controllare di controlli "Se".
Esempio. Supponiamo che in B5 ci sia il numero da "convertire".

In B10 metti:
Codice: Seleziona tutto
=SE(B5>=1;"X";"")


In B11:
Codice: Seleziona tutto
=SE(B5>=2;"X";"")


In B12:
Codice: Seleziona tutto
=SE(B5>=3;"X";"")


E così via.

Resta da stabilire cosa si vuol fare con il valore 0 (Zero)... ma non credo sia un problema.

Ciao,
MAx
Avatar utente
maxmula
Utente Senior
 
Post: 965
Iscritto il: 18/08/04 18:28
Località: N44°59'45 E09°00'34


Torna a Applicazioni Office Windows


Topic correlati a "Excel trasformare un numero in X":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti