Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel

Postdi Statix » 26/05/10 13:06

Ciao a tutti,
un quesito abbastanza facile,al momento non mi vine la formula,
ho in un range C1:G1 5 numeri
dovrei fare in modo di riportare i numeri appartenenti ad una decina in una cella.
esempio

range C1:G1
1-34-5-67-8-90
in L1 1-5-8
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Sponsor
 

Re: Excel

Postdi Flash30005 » 26/05/10 14:11

Prova questa
Codice: Seleziona tutto
=SE(C1<10;C1&"-";"")&SE(D1<10;D1&"-";"")&SE(E1<10;E1&"-";"")&SE(F1<10;F1&"-";"")&SE(G1<10;G1&"-";"")&SE(H1<10;H1;"")

Se vuoi che sia inserito anche il valore 10 modifica la formula con <11 (invece che 10)

Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel

Postdi Statix » 26/05/10 14:20

Ciao Flash30005,
la formula va bene per la decina che ho descritto,
volendo adattare la formula anche per le altre decine,
mi ricordo tempo fa , Anthony mi fece fare una Tabella per ogni decina con Definisci con nome,
e che poi usavo per far ciò ma non sono riuscito più a trovarla.
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Excel

Postdi Statix » 26/05/10 15:00

Ciao Flash30005,
mi sono ricordato,va bene così,questa per una decina
Codice: Seleziona tutto
=Se(CONTA.SE(Decina1;C1)=1;C1;"-")&" - "&SE(CONTA.SE(Decina1;D1)=1;D1;"-")&" - "&SE(CONTA.SE(Decina1;E1)=1;E1;"-")&" - "&SE(CONTA.SE(Decina1;F1)=1;F1;"-")&" - "&SE(CONTA.SE(Decina1;G1)=1;G1;"")
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Excel

Postdi Flash30005 » 26/05/10 15:53

Nel frattempo avrei fatto questo
in U1 e V9 crei la tabella
Codice: Seleziona tutto
U     V
1    10
11   20
21   30
31   40
41   50
51   60
61   70
71   80
81   90

In L1 inseirsci questa formula
Codice: Seleziona tutto
=SE(E($C1>=INDIRETTO("U" & RIF.COLONNA()-11;$U1);$C1<=INDIRETTO("V" & RIF.COLONNA()-11;$V1));$C1&"-";"")&SE(E($D1>=INDIRETTO("U" & RIF.COLONNA()-11;$U1);$D1<=INDIRETTO("V" & RIF.COLONNA()-11;$V1));$D1&"-";"")&SE(E($E1>=INDIRETTO("U" & RIF.COLONNA()-11;$U1);$E1<=INDIRETTO("V" & RIF.COLONNA()-11;$V1));$E1&"-";"")&SE(E($F1>=INDIRETTO("U" & RIF.COLONNA()-11;$U1);$F1<=INDIRETTO("V" & RIF.COLONNA()-11;$V1));$F1&"-";"")&SE(E($G1>=INDIRETTO("U" & RIF.COLONNA()-11;$U1);$G1<=INDIRETTO("V" & RIF.COLONNA()-11;$V1));$G1&"-";"")&SE(E($H1>=INDIRETTO("U" & RIF.COLONNA()-11;$U1);$H1<=INDIRETTO("V" & RIF.COLONNA()-11;$V1));$H1;"")

Che copierai in orizzontale fino alla colonna "T" per avere le nove decine
poi trascini L1:T1 per tutte le righe che occorrono

Certo che è uscito un formulone,
ma vedo che nel frattempo hai risolto...

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel

Postdi Statix » 26/05/10 16:05

Ciao Flash30005,
mi dispiace,non volevo farti perdere del tempo,
capita a volte che non mi ricordi delle cose
e le chiedo sul forum,ipotizzando che per te ed Anthony
siano delle schiocchezze ,visto il vostro grado di altissima preparazione,
la colpa è sempre nostra,perchè non esponiamo bene cosa vogliamo fare e ottenere
dalle formule o dalle macro,sarebbe opportuno per voi moderatori,
commentare di più sia le formule che le macro,lo so che questo richiede più tempo,
ma come dice un proverbio: Se dai un pesce ad un uomo per sfamarlo,lo sfamerai per un giorno,
ma se gli insegni a pescare,lo sfamerai per tutta la vita. ;) ;)
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta


Torna a Applicazioni Office Windows


Topic correlati a "Excel":


Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti