Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[EXCEL] "Annidiare" formula SE

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[EXCEL] "Annidiare" formula SE

Postdi rambler1985 » 19/05/10 07:53

ho un problema con la formula SE.
In particolare dovrei riusire ad annidiarla (spero si dica così) nel seguente modo:

Immagine

a seconda del valore in b2, a2 dovrà avere il seguente valore:
-se b2 è compreso tra 0 e 1, allora -> SCARTO(calendario;CONFRONTA(A1;calendario;0)+0;0), ovvero scarta un numero di posizioni pari a 0 dalla cella a1., prendendo riferimento da un foglio detto calendario, dove sono elencate le date

-se b2 è compreso tra 1 e 2, allora -> SCARTO(calendario;CONFRONTA(A1;calendario;0)+1;0), ovvero scarta un numero di posizioni pari a 1 dalla cella a1., prendendo riferimento da un foglio detto calendario, dove sono elencate le date

-se b2 è compreso tra 2 e 3, allora -> SCARTO(calendario;CONFRONTA(A1;calendario;0)+2;0), ovvero scarta un numero di posizioni pari a 1 dalla cella a1., prendendo riferimento da un foglio detto calendario, dove sono elencate le date

-etc...

io ho scritto questa, con esempio fino a b2 compreso tra 1 e 2:
=SE(B2<1;SCARTO(calendario!$A$2;CONFRONTA(A1;calendario;0)+0;0);SE(B2<2;SCARTO(calendario!$A$2;CONFRONTA(A1;calendario;0)+1;0;SE(B2<3;SCARTO(calendario!$A$2;CONFRONTA(A1;calendario;0)+2;0)))

ma funziona solo per il VERO

Grazie
rambler1985
Newbie
 
Post: 7
Iscritto il: 03/05/10 19:53

Sponsor
 

Re: [EXCEL] "Annidiare" formula SE

Postdi ricky53 » 19/05/10 08:15

Ciao,

il tuo "-etc..." per le condizioni degli intervalli fino a che valore deve arrivare ?
Se le condizioni sono molte la leggibilità e la manutenibilità della formula diventano diffiicili.

Non so se la versione 2007 ha dei limiti sulle condizioni "annidate"; per excel 2003 il limite è "7".

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [EXCEL] "Annidiare" formula SE

Postdi rambler1985 » 19/05/10 08:27

fino al limite (sette) va benissimo
rambler1985
Newbie
 
Post: 7
Iscritto il: 03/05/10 19:53

Re: [EXCEL] "Annidiare" formula SE

Postdi ricky53 » 19/05/10 12:07

Ciao,

prova con:

Codice: Seleziona tutto
=SE(E(B2>=0; B2<=1); "Primo Scarto +0"; SE(E(B2>1; B2<=2); "Secondo Scarto +1"; SE(E(B2>2; B2<=3); "Terzo scarto +2"; "Formule per altri scarti che devi inserire TU")))


la formula che ti ho proposto è parlante: opera di conseguenza.

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [EXCEL] "Annidiare" formula SE

Postdi Anthony47 » 19/05/10 13:40

Forse si puo' ridurre a
Codice: Seleziona tutto
=SCARTO(Calendario!$A$2;CONFRONTA(A1;Calendario!$A$2;0)+INT(B2/2);0)

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[EXCEL] "Annidiare" formula SE":


Chi c’è in linea

Visitano il forum: patel e 12 ospiti