Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel: cacolo distanza tra due celle con lo stesso valore

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel: cacolo distanza tra due celle con lo stesso valore

Postdi doc11 » 16/05/10 15:28

Qualcuno per favore mi aiuterebbe a trovare la formula corretta per calcolare in una matrice la distanza in righe tra due celle che abbiano lo stesso valore anche se posizionate su colonne diverse ?

Immagine

Nella matrice qui sopra, ad esempio, mi servirebbe una formula per calcolare quante righe intercorrono tra la cella A11 e la cella D7 che contengono lo stesso valore (88). Il risultato dovrebbe essere 4.

Grazie mille
doc11
Newbie
 
Post: 3
Iscritto il: 16/05/10 15:02

Sponsor
 

Re: Excel: cacolo distanza tra due celle con lo stesso valore

Postdi doc11 » 16/05/10 15:42

Scusate, ecco l'immagine di esempio:
Immagine
doc11
Newbie
 
Post: 3
Iscritto il: 16/05/10 15:02

Re: Excel: cacolo distanza tra due celle con lo stesso valore

Postdi tutamimetica » 16/05/10 16:22

in G2 =CONTA.SE(A2:F2;88)
in H2 =SE(G2=1;RIF.RIGA(G2);"")
in I2 =SE(H2="";"";SE(VAL.ERRORE(GRANDE($H$1:H2;1)-GRANDE($H$1:H2;2))=VERO;"";GRANDE($H$1:H2;1)-GRANDE($H$1:H2;2)))
Evidenzi da G2 a I2 e copi con il trascinamento fino a ... dove vuoi.
tuta
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25

Re: Excel: cacolo distanza tra due celle con lo stesso valore

Postdi doc11 » 16/05/10 20:14

Grazie mille, veramente.
doc11
Newbie
 
Post: 3
Iscritto il: 16/05/10 15:02

Re: Excel: cacolo distanza tra due celle con lo stesso valore

Postdi biancocandido55 » 24/05/10 08:22

Ciao ragazzi,
scusate l'intromissione,
domandina x tuta
così a colpo d'occhio sembrano le formule usate per il calcolo dei ritardi d'estratto su un archivio dati lotto, giusto?
se la risposta è positiva, segue domanda,
si può provare a creare un'unica formula o funzione che faccia il lavoro delle 3 citate sopra?
Scusate e grazie
ciao bianco55
biancocandido55
Utente Senior
 
Post: 305
Iscritto il: 03/03/06 10:15

Re: Excel: cacolo distanza tra due celle con lo stesso valore

Postdi Anthony47 » 24/05/10 14:33

Ad esempio questa, che calcola la differenza di righe prendendo come confronto il numero contenuto in H1 e l' area A1:E100.
Codice: Seleziona tutto
=PICCOLO(SE(A1:E100=H1;RIF.RIGA(A1:E100);"");2)-PICCOLO(SE(A1:E100=H1;RIF.RIGA(A1:E100);"");1)
Da confermare con Contr-Maiusc-Enter

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel: cacolo distanza tra due celle con lo stesso valore

Postdi biancocandido55 » 28/05/10 18:23

Ciao ragazzi,
scusatemi se ho riuppato questo topic ma la domanda è inerente l'argomento.

Per Antony,
ciao Anthony, allora, prendendo spunto dalla formula che avevi postato nell'ultimo messaggio, volevo chiederti se puoi modificare la stessa, in modo da calcolare la differenza di righe prendendo come confronto i numeri contenuti in 2 celle per es: G1,H1 nella stessa riga e l' area A1:E100.
grazie 10.000 e un saluto a pre,
bianco55 Immagine
biancocandido55
Utente Senior
 
Post: 305
Iscritto il: 03/03/06 10:15


Torna a Applicazioni Office Windows


Topic correlati a "Excel: cacolo distanza tra due celle con lo stesso valore":


Chi c’è in linea

Visitano il forum: PcBase e 6 ospiti