Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[EXCEL] problemi con formula SCARTO

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[EXCEL] problemi con formula SCARTO

Postdi rambler1985 » 03/05/10 20:22

Saluti a tutti.
Ho un problema che cercherò di esprimere nel modo più chiaro possibile.
Ho due fogli di lavoro chiamati FOGLIO 1 e FOGLIO 2 (che fantasia!).
Il FOGLIO 1 è il foglio di lavoro, dove segno, tra le altre, la data di inizio di una produzione, il numero di turni necessari ad ultimarla e la fine della stessa. Nell'immagine sottostante non è indicato, ma il numero di turni necessari ad ultimare una produzione sono uguali a:
NUMERO METRI DA PRODURRE / NUMERO METRI PER TURNO (dato fisso)

Immagine

Nel FOGLIO 2 elenco un calendario di giorni lavorativi, in cui ho escluso manualmente i giorni non lavorativi (sabati, domeniche ed altri). Ho inoltre nominato l'intervallo A2:A19 "calendario", come da immagine.

Immagine



Il mio problema è quindi trovare una formula (scarto? che però non riseco a usare perchè sono fogli differenti) da porre nelle varie celle B2,3,4,5,etc.. che, una volta inserita la data di inizio X e la durata Y, mi dia come risultato una data di fine pari a X scalata di Y posizioni.

Ecco un esempio:
data inizio: venerdì 8 gennaio
durata: 2 turni
data finale: lunedì 11 gennaio

con una semplice somma (8 gennaio +2) mi darebbe come risultato domenica 10.

Spero di essermi spiegato bene e grazie. :undecided:
rambler1985
Newbie
 
Post: 7
Iscritto il: 03/05/10 19:53

Sponsor
 

Re: [EXCEL] problemi con formula SCARTO

Postdi ricky53 » 03/05/10 23:21

Ciao,
prova con

Codice: Seleziona tutto
=SE(GIORNO.SETTIMANA(A3+2; 2)=6; A3+Num_Turni + 2; SE(GIORNO.SETTIMANA(A3+2; 2)=7; A3+ Num_Turni+1; A3+ Num_Turni))


dove "A3" è la data di inizio.

Al posto di "Num_Turni" devi mettere:
1. la cella che contiene il numeri di turni
oppure
2. la formula per calcolari.

Meglio la soluzione "1".

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [EXCEL] problemi con formula SCARTO

Postdi rambler1985 » 04/05/10 07:55

grazie ricky

la tua formula funziona benissimo con i venerdì (es venerdi + 2turni mi da giustamente lunedi e non domenica), ma con gli altri giorni settimanali mi conta un giorno in più (es lunedi più due turni mi da mercoledi, ma dovrebbe essere martedi, perchè occorre contare anche lunedi stesso)

magari utilizzando il foglio dei giorni lavorativi si potrebbe chiedere una cosa del tipo:

cerca il valore di A3 del foglio1 (quello di lavoro) nel foglio 2 (calendario) e a questo scala un numero di posizioni pari a d3 (numero di turni)
che poi anche qui ci sarebbe da scalare un numero di posizioni pari a d3 meno 1 se d3 è diverso da zero, e se d3 è uguale a 0 occorre scalare solo d3 (senza il meno 1)

mi affido comunque al vostro genio
sono nelle vostre mani
rambler1985
Newbie
 
Post: 7
Iscritto il: 03/05/10 19:53

Re: [EXCEL] problemi con formula SCARTO

Postdi rambler1985 » 04/05/10 08:07

quindi potrebbe essere una cosa del tipo:
"cerca A3 del foglio 1 nel foglio 2 (il calendario) e:
-se d3>0, scala un numero di posizioni da a3 pari a d3-1
-se d3=0, scala un numero di posizioni da a3 pari a d3."

scusate il doppio post
rambler1985
Newbie
 
Post: 7
Iscritto il: 03/05/10 19:53

Re: [EXCEL] problemi con formula SCARTO

Postdi ricky53 » 04/05/10 15:42

Caio,
allora prova con questa

Codice: Seleziona tutto
=SE(GIORNO.SETTIMANA(A3+2; 2)=6; A3+Num_Turni + 2; SE(GIORNO.SETTIMANA(A3+2; 2)=7; A3+ Num_Turni+1; A3+ Num_Turni - 1))


Ho tolto 1 giorno allla condizione: A3+ Num_Turni che vale per i giorni lavorativi

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [EXCEL] problemi con formula SCARTO

Postdi rambler1985 » 04/05/10 15:48

sei gentilissimo
appena posso provo
e ti faccio sapere
grazie
rambler1985
Newbie
 
Post: 7
Iscritto il: 03/05/10 19:53

Re: [EXCEL] problemi con formula SCARTO

Postdi Anthony47 » 04/05/10 22:16

Ciao rumbler1985 e benvenuto nel forum, ciao Ricky.
Se rumbler ha gia' prodotto un elenco con i giorni lavorativi ("calendario"), allora dovrebbe anche essere possibile usare in B3 di Foglio1 la formula
Codice: Seleziona tutto
=SCARTO(calendario;CONFRONTA(A3;calendario;0)+D3-1;0)
Poi si copia B3 nelle celle sottostanti.
Questo presuppone che A3 contenga la data di inizio (che deve essere in "calendario") e in D3 ci sia scritto quanti turni servono per quella produzione.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [EXCEL] problemi con formula SCARTO

Postdi ricky53 » 04/05/10 23:31

Ciao,
indubbiamente la soluzione di Anthony è migliore ed ottimizzata, solo calcola, a mio avviso, un giorno in più.

Io la modificherei in

SCARTO(Calendario; CONFRONTA(A3;Calendario;0) + D3 - 2; 0; 1; 1)

La mia oltre i 5 giorni di lavorazione non è più esatta perchè calcola i sab e le dom.

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [EXCEL] problemi con formula SCARTO

Postdi rambler1985 » 05/05/10 13:01

perfetto ragazzi

funziona alla grande.
siete stati gentilissimi

grazie mille
rambler1985
Newbie
 
Post: 7
Iscritto il: 03/05/10 19:53


Torna a Applicazioni Office Windows


Topic correlati a "[EXCEL] problemi con formula SCARTO":


Chi c’è in linea

Visitano il forum: Nessuno e 31 ospiti