Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Contare il numero di valori univoci su più colonne

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Contare il numero di valori univoci su più colonne

Postdi Hardluc » 17/02/10 09:44

Salve,
ho un problema che non riesco a risolvere:
Su un foglio Excel ho inserito su diverse colonne il nome dei clienti e poi a seguire, la data della prestazione ed il tipo di prestazione eseguita. La funzione che non riesco ad inserire è il conteggio dei giorni di lavoro totali.
In pratica ho bisogno di poter contare il numero di date univoche su più colonne( nove per la precisione).
il tutto ciò possibilmente su un foglio differente nella medesima cartella di Excel.

Grazie tutti
Hardluc
Newbie
 
Post: 1
Iscritto il: 17/02/10 09:36

Sponsor
 

Re: Contare il numero di valori univoci su più colonne

Postdi Flash30005 » 17/02/10 09:58

Ciao Hardluc e benvenuto

A mio avviso non è molto chiara la distribuzione dei dati.
Potresti pubblicare un'immagine del foglio o, meglio, un file modificando i dati sensibili?

qui potrai vedere come allegare file o immagini

Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Contare il numero di valori univoci su più colonne

Postdi Anthony47 » 17/02/10 16:05

Confermo quanto detto da Flash sulla poca chiarezza nella descrizione della struttura dati. Comunque se parli di 9 colonne adiacenti, ad esempio posizionate in H1:P1, allora potresti usare una formula come questa:
Codice: Seleziona tutto
=SOMMA(SE(CONTA.SE($H$1:$P$1;H1:P1)>1;1/CONTA.SE($H$1:$P$1;H1:P1);SE(H1:P1>0;1;0)))
che confermerai con Contr-Maiusc-Enter.
Una volta che funziona sul foglio che contiene gia' le date, fai Contr-x (taglia) vai su altro foglio e fai Enter nella posizione in cui vuoi il riultato.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Contare il numero di valori univoci su più colonne":


Chi c’è in linea

Visitano il forum: patel e 14 ospiti